2012ICPC长春站 B Candy 【快速排列组合】

Font Size: ← →

Problem Description

LazyChild is a lazy child who likes candy very much. Despite being very young, he has two large candy boxes, each contains n candies initially. Everyday he chooses one box and open it. He chooses the first box with probability p and the second box with probability (1 - p). For the chosen box, if there are still candies in it, he eats one of them; otherwise, he will be sad and then open the other box.
He has been eating one candy a day for several days. But one day, when opening a box, he finds no candy left. Before opening the other box, he wants to know the expected number of candies left in the other box. Can you help him?

Input

There are several test cases.
For each test case, there is a single line containing an integer n (1 ≤ n ≤ 2 × 105) and a real number p (0 ≤ p ≤ 1, with 6 digits after the decimal).
Input is terminated by EOF.

Output

For each test case, output one line “Case X: Y” where X is the test case number (starting from 1) and Y is a real number indicating the desired answer.
Any answer with an absolute error less than or equal to 10-4 would be accepted.

Sample Input

10 0.400000
100 0.500000
124 0.432650
325 0.325100
532 0.487520
2276 0.720000

Sample Output

Case 1: 3.528175
Case 2: 10.326044
Case 3: 28.861945
Case 4: 167.965476
Case 5: 32.601816
Case 6: 1390.500000

Source

2012 Asia Chengdu Regional Contest

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<iomanip>
#include<string>
#include<vector>
#include<stack>
#include<queue>
#include<cmath>
#include<functional>
using namespace std;
#define LL long long int 
#define INF 0x3f3f3f3f
const int maxn = 1e5 + 10;
const int MOD = 1e9 + 7;
double x, y; int n;
double logn[maxn];
double C(int n, int m)
{
    return logn[n] - logn[m] - logn[n - m];
}
int main()
{
    memset(logn, 0.0, sizeof(logn));
    for (int i = 1; i < maxn; i++)
    {
        logn[i] = logn[i - 1] + log(i*1.0);
    }
    int k = 0;
    while (cin >> n)
    {
        k++;
        cin >> x;
        y = 1.0 - x;
        if(x>y)
        swap(x, y);
        x = log(x);
        y = log(y);
        double ans = 0;//期望
        for (int i = 0; i < n + 1; i++)
        {
            ans += i*(exp(C(2 * n - i, n) + (n + 1)*x + (n - i)*y));
            ans    += i*(exp(C(2 * n - i, n) + (n + 1)*y + (n - i)*x));
        }
        cout << "Case " << k << ": " << setiosflags(ios::fixed) << setprecision(6) << ans << endl;
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值