HDU 3478 Catch【kurskal+二分图染色】

Problem Description
A thief is running away!
We can consider the city where he locates as an undirected graph in which nodes stand for crosses and edges stand for streets. The crosses are labeled from 0 to N–1.
The tricky thief starts his escaping from cross S. Each moment he moves to an adjacent cross. More exactly, assume he is at cross u at the moment t. He may appear at cross v at moment t + 1 if and only if there is a street between cross u and cross v. Notice that he may not stay at the same cross in two consecutive moment.
The cops want to know if there’s some moment at which it’s possible for the thief to appear at any cross in the city.

Input
The input contains multiple test cases:
In the first line of the input there’s an integer T which is the number of test cases. Then the description of T test cases will be given.
For any test case, the first line contains three integers N (≤ 100 000), M (≤ 500 000), and S. N is the number of crosses. M is the number of streets and S is the index of the cross where the thief starts his escaping.
For the next M lines, there will be 2 integers u and v in each line (0 ≤ u, v < N). It means there’s an undirected street between cross u and cross v.

Output
For each test case, output one line to tell if there’s a moment that it’s possible for the thief to appear at any cross. Look at the sample output for output format.

Sample Input
2
3 3 0
0 1
0 2
1 2
2 1 0
0 1

Sample Output
Case 1: YES
Case 2: NO

Hint
For the first case, just look at the table below. (YES means the thief may appear at the cross at that moment)

For the second input, at any moment, there’s at least one cross that the thief can’t reach.

Source
2010 ACM-ICPC Multi-University Training Contest(5)——Host by BJTU

Recommend
zhengfeng | We have carefully selected several similar problems for you: 3486 3485 3484 3483 3482

题意:有个小偷跑啊跑,问能不能在某一时刻经过所有城市。u和v之间有一条街道,小偷来回在两条街道之间穿梭。

分析:首先这个图要是个连通图,并且还是二分图。
前者kruskal,后者染色。

#include<cstdio>
#include<iostream>
#include<iomanip>
#include<algorithm>
#include<queue>
#include<vector>
using namespace std;
#define Irish_Moonshine main
const int maxn = 1e5 + 10;
vector<int >mp[maxn];
int f[maxn];
int color[maxn];//0 wei ran se 1||2
int n, m, s;
int find(int a)
{
    int r = a;
    while (f[r] != r)// his top father
    {
        r = f[r];
    }
    int i = a;
    int j;
    while (i != r)
    {
        j = f[i];
        f[i] = r;
        i = j;
    }
    return r;
}
void merge(int a, int b)
{
    int x, y;
    x = find(a);
    y = find(b);
    if (x != y)
        f[y] = x;
}
int bfs(int x)
{
    queue<int >s;
    s.push(x);
    color[x] = 1;
    while (!s.empty())
    {
        int tmp = s.front();
        s.pop();
        for (int i = 0; i < mp[tmp].size(); i++)
        {
            int v = mp[tmp][i];
            if (color[v])
            {
                if (color[tmp] == color[v])
                    return 0;
            }
            else
            {
                color[v] = 3-color[tmp];
                s.push(v);
            }
        }
    }
    return 1;
}
int Irish_Moonshine()
{
    int t;
    int cs = 0;
    scanf("%d", &t);
    while (t--)
    {
        cs++;
        scanf("%d%d%d", &n, &m, &s);
        for (int i = 0; i <= n; i++)
        {
            color[i] = 0;
            f[i] = i;
            mp[i].clear();
        }
        for (int i = 0; i < m; i++)
        {
            int u, v;
            scanf("%d%d", &u, &v);
            mp[u].push_back(v);
            mp[v].push_back(u);
            merge(u, v);//kruskal
        }
        int cnt = 0;
        for (int i = 0; i < n; i++)//kruskal 1
        {
            if (f[i] == i)cnt++;
        }
        if (cnt == 1)
        {
            int tmp = bfs(s);
            if (tmp!=0)
            {
                printf("Case %d: NO\n", cs);
            }
            else
            {
                printf("Case %d: YES\n", cs);
            }
        }
        else
        {
            printf("Case %d: NO\n", cs);
        }

    }
    //system("pause");
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值