poj 1679 The Unique MST [Kurskal 最小生成树是否唯一:次小生成树]

The Unique MST

poj 1679题目链接

Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 34429 Accepted: 12559

Description

Given a connected undirected graph, tell if its minimum spanning tree is unique.

Definition 1 (Spanning Tree): Consider a connected, undirected graph G = (V, E). A spanning tree of G is a subgraph of G, say T = (V’, E’), with the following properties:

  1. V’ = V.
  2. T is connected and acyclic.

Definition 2 (Minimum Spanning Tree): Consider an edge-weighted, connected, undirected graph G = (V, E). The minimum spanning tree T = (V, E’) of G is the spanning tree that has the smallest total cost. The total cost of T means the sum of the weights on all the edges in E’.

Input

The first line contains a single integer t (1 <= t <= 20), the number of test cases. Each case represents a graph. It begins with a line containing two integers n and m (1 <= n <= 100), the number of nodes and edges. Each of the following m lines contains a triple (xi, yi, wi), indicating that xi and yi are connected by an edge with weight = wi. For any two nodes, there is at most one edge connecting them.

Output

For each input, if the MST is unique, print the total cost of it, or otherwise print the string ‘Not Unique!’.

Sample Input

2
3 3
1 2 1
2 3 2
3 1 3
4 4
1 2 2
2 3 2
3 4 2
4 1 2

Sample Output

3
Not Unique!

Source

POJ Monthly–2004.06.27 srbga@POJ

解题思路

题意比较简单,就是说最小生成树是否唯一。也就是求次小生成树,判断是否有次小生成树和最小生成树的值相同。

这里我用的Kurskal ,比较容易理解。次小生成树,在最小生成树的基础上,加上一条边,让他构成一个环,然后在这个环里面去掉一个最大的边,剩下的树就是次小生成树了。不过要记得就是对每一条边都要进行替换,看是否能找到相等的值的生成树。

Kurskal 实现的话比 prime 更容易理解一点的,也更容易实现。因为Kurskal 算法就是根据边来找生成树的。

程序代码

#include <stdio.h>
#include <string.h>
#include <algorithm>
#define inf 99999999
using namespace std;
int pur[110];

struct node{
	int u,v,l;
	int h;		//判断边是否用过 
};
node q[100010];
int cmp(node a,node b){
	return a.l<b.l;
}

int find(int x){
	if(pur[x]==x)
		return x;
	else
		pur[x]=find(pur[x]);
	return pur[x];
}

int merge(int u,int v){		//如果集合里面没有,就可以加进来 
	int t1=find(u);
	int t2=find(v);
	if(t1!=t2){
		pur[t1]=t2;
		return 1;
	}
	return 0;
}

int Kurskal(int n,int m,int v){		//求最小生成树 
	int i,j,k;
	for(i=0;i<=n;i++)
		pur[i]=i;
	j=0; k=0;
	for(i=0;i<m;i++){
		if(q[i].l!=inf&&merge(q[i].u,q[i].v)){
			j++;
			k+=q[i].l;
			if(v==1)				//标记最小生成树用过哪些边 
				q[i].h=1;			//次小生成树则不用进行标记 
		}
		if(j==n-1)
			break;
	}
	if(j==n-1)
		return k;
	return -1;
}

int main()
{
	int t,n,m,p;
	int i,j,k,ans,flag;
	scanf("%d",&t);
	while(t--){
		scanf("%d%d",&n,&m);
		for(i=0;i<m;i++){
			scanf("%d%d%d",&q[i].u,&q[i].v,&q[i].l);
			q[i].h=0;
		}
		flag=0;
		sort(q,q+n,cmp);
		
		ans=Kurskal(n,m,1);		//这里就是当前图的最小生成树 
		
		for(i=0;i<m;i++){		//这里是求次小生成树 
			if(!q[i].h)			//这条边必须要用过 
				continue;
			p=q[i].l;
			
			q[i].l=inf;			//分别把每一条最小生成树用过的边都清除掉 
			 
			k=Kurskal(n,m,0);	//然后再次寻找最小生成树 
			
			q[i].l=p;			//清除掉的边再变回来,循环清除下一条边 
			
			if(k==ans){			//相等说明次小生成树出现与最小生成树相等的值 
				flag=1;
				break;
			}
		}
		if(flag)
			printf("Not Unique!\n");
		else
			printf("%d\n",ans);
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值