POJ 3255 Roadblocks【次短路】

Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 16506 Accepted: 5821
Description

Bessie has moved to a small farm and sometimes enjoys returning to visit one of her best friends. She does not want to get to her old home too quickly, because she likes the scenery along the way. She has decided to take the second-shortest rather than the shortest path. She knows there must be some second-shortest path.

The countryside consists of R (1 ≤ R ≤ 100,000) bidirectional roads, each linking two of the N (1 ≤ N ≤ 5000) intersections, conveniently numbered 1..N. Bessie starts at intersection 1, and her friend (the destination) is at intersection N.

The second-shortest path may share roads with any of the shortest paths, and it may backtrack i.e., use the same road or intersection more than once. The second-shortest path is the shortest path whose length is longer than the shortest path(s) (i.e., if two or more shortest paths exist, the second-shortest path is the one whose length is longer than those but no longer than any other path).

Input

Line 1: Two space-separated integers: N and R
Lines 2..R+1: Each line contains three space-separated integers: A, B, and D that describe a road that connects intersections A and B and has length D (1 ≤ D ≤ 5000)
Output

Line 1: The length of the second shortest path between node 1 and node N
Sample Input

4 4
1 2 100
2 4 200
2 3 250
3 4 100
Sample Output

450
Hint

Two routes: 1 -> 2 -> 4 (length 100+200=300) and 1 -> 2 -> 3 -> 4 (length 100+250+100=450)
Source

USACO 2006 November Gold

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<queue>
#include<vector>
#include<functional>
using namespace std;
const int maxn = 1e5 + 50;
#define INF 0x3f3f3f3f
#define ll long long int
int d[maxn];
int d2[maxn];
int k;
//vector<int> G[maxn];
//vector<int> len[maxn];
int M, N;
int head[maxn];
int vis[maxn][2];
int dis[maxn][2];
struct edge {
    int to;
    int nx;
    int w;
}mp[2*maxn];
void add(int u, int v, int w)
{
    mp[k].to = v;
    mp[k].w = w;
    mp[k].nx = head[u];
    head[u] = k++;
}
void dijksta()
{
    for (int i = 1; i <= N; i++)
    {
        dis[i][0] = dis[i][1] = INF;
    }
    dis[1][0] = 0;
    int u, v;
    for (int i = 1; i <= N * 2; i++)
    {
        int Min = INF;
        for (int j = 1; j <= N; j++)
        {
            if (vis[j][0] == 0 && dis[j][0] < Min)
            {
                u = j;
                v = 0;
                Min = dis[j][0];
            }
            else if (vis[j][1] == 0 && dis[j][1] < Min)
            {
                u = j;
                v = 1;
                Min = dis[j][1];
            }
        }
        if (Min == INF)
            break;
        vis[u][v] = 1;
        for (int i = head[u]; i != -1; i = mp[i].nx)
        {
            int s = mp[i].to;
            int dist = Min + mp[i].w;
            if (dis[s][0]>dist)  
            {
                dis[s][1] = dis[s][0];
                dis[s][0] = dist;
            }
            else if (dis[s][1]>dist)  
                dis[s][1] = dist;
        }

    }
    printf("%d\n", dis[N][1]);
}
int main()
{
    scanf("%d%d", &N, &M);

        k = 0;
        memset(head, -1, sizeof(head));
        memset(vis, 0, sizeof(vis));
        //memset(dis, 0, sizeof(dis));
        while (M--)
        {
            int u, v, w;
            scanf("%d%d%d", &u, &v, &w);
            add(u, v, w);
            add(v, u, w);
        }
        dijksta();

    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值