HDU 2669 Romantic 【exgcd】

Romantic
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 7728 Accepted Submission(s): 3276

Problem Description

The Sky is Sprite.
The Birds is Fly in the Sky.
The Wind is Wonderful.
Blew Throw the Trees
Trees are Shaking, Leaves are Falling.
Lovers Walk passing, and so are You.
…………………………..Write in English class by yifenfei

Girls are clever and bright. In HDU every girl like math. Every girl like to solve math problem!
Now tell you two nonnegative integer a and b. Find the nonnegative integer X and integer Y to satisfy X*a + Y*b = 1. If no such answer print “sorry” instead.

Input

The input contains multiple test cases.
Each case two nonnegative integer a,b (0<a,b<=pow(2,31))

Output

output nonnegative integer X and integer Y, if there are more answers than the X smaller one will be choosed. If no answer put “sorry” instead.

Sample Input

77 51
10 44
34 79

Sample Output

2 -3
sorry
7 -3

Author

yifenfei

Source

HDU女生专场公开赛——谁说女子不如男

Recommend

lcy | We have carefully selected several similar problems for you: 2668 2674 2671 2670 2672

典型的解丢番图方程(线性方程)
扩展欧几里得求解:

#include<iostream>
#include<cstring>
#include<iomanip>
#include<algorithm>
using namespace std;
#define ll long long int
ll i_gcd(ll a, ll b)
{
    if (b == 0)
        return a;
    else
        return i_gcd(b, a%b);
}
ll e_gcd(ll a, ll b, ll &x, ll &y)
{
    if (b == 0)
    {
        x = 1;
        y = 0;
        return a;
    }
    ll ans = e_gcd(b, a%b, x, y);
    ll temp = x;
    x = y;
    y = temp - a / b*y;
    /*          x = y1
    y = x1 – a / b*y1                 */
    return ans;
}
//ll cal(ll a, ll m)//求逆元
//{
//  ll x, y;
//  ll gcd = e_gcd(a, m, x, y);
//  if (1 % gcd != 0)
//      return -1;
//  x *= 1 / gcd;
//  m = abs(m);
//  ll ans = (x%m + m) % m;
//  return ans;
//}
int main()
{
    ll m, n;
    while (~scanf("%lld %lld", &m, &n))
    {
        ll x, y;
        //ll tmp = i_gcd(m, n);
        if (e_gcd(m, n, x, y) != 1ll)
        {
            printf("sorry\n");
            continue;
        }
        /*x = y = 0ll;
        ll ans = e_gcd(m, n, x, y);*/
        /*if ((m*x + n*y) != 1ll)
        {
            printf("sorry\n");
            continue;
        }*/
        while (x < 0)
        {
            x += n;
            y -= m;
        }
        printf("%lld %lld\n", x, y);

    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值