HDU 2669 【Exgcd正宗模板】

 Romantic

Time Limit:1000MS Memory Limit:32768KB 64bit IO Format:%I64d & %I64u
 
Description
The Sky is Sprite.
The Birds is Fly in the Sky.
The Wind is Wonderful.
Blew Throw the Trees
Trees are Shaking, Leaves are Falling.
Lovers Walk passing, and so are You.
................................Write in English class by yifenfei



Girls are clever and bright. In HDU every girl like math. Every girl like to solve math problem!
Now tell you two nonnegative integer a and b. Find the nonnegative integer X and integer Y to satisfy X*a + Y*b = 1. If no such answer print "sorry" instead.
Input
The input contains multiple test cases.
Each case two nonnegative integer a,b (0<a, b<=2^31)
Output
output nonnegative integer X and integer Y, if there are more answers than the X smaller one will be choosed. If no answer put "sorry" instead.
Sample Input
77 51
10 44
34 79
Sample Output
2 -3
sorry

7 -3


题意:求ax+by=1的最小x非负解;

思路:Exgcd即可;

失误:用int 就是wa,估计一下用int可以的,这种东西以后不要费心啦直接LL吧;


AC代码:

#include<cstdio>

typedef long long LL;

LL Exgcd(LL a,LL b,LL &x,LL &y)
{
	if(!b)
	{
		x=1; y=0;
		return a;
	}
	LL R=Exgcd(b,a%b,y,x);
	y-=a/b*x;
	return R;
 } 
 
int main()
{
	LL a,b;
	while(~scanf("%lld %lld",&a,&b))
	{
		LL x=0,y=0; 
		LL d=Exgcd(a,b,x,y);
		if(1%d) {
			printf("sorry\n");
			continue;
		}
		x=1/d*x;
		LL mod=b/d;
		x=(x%mod+mod)%mod;
		y=(1-a*x)/b;
		printf("%lld %lld\n",x,y);
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值