2017 CCPC 秦皇岛 L - One-Dimensional Maze 【water】

BaoBao is trapped in a one-dimensional maze consisting of grids arranged in a row! The grids are numbered from 1 to from left to right, and the -th grid is marked with a character , where is either ‘L’ or ‘R’.

Starting from the -th grid, BaoBao will repeatedly take the following steps until he escapes the maze:

If BaoBao is in the 1st grid or the -th grid, then BaoBao is considered to arrive at the exit and thus can escape successfully.
Otherwise, let BaoBao be in the -th grid. If , BaoBao will move to the -th grid; If , Baobao will move to the -th grid.
Before taking the above steps, BaoBao can change the characters in some grids to help himself escape. Concretely speaking, for the -th grid, BaoBao can change from ‘L’ to ‘R’, or from ‘R’ to ‘L’.

But changing characters in grids is a tiring job. Your task is to help BaoBao calculate the minimum number of grids he has to change to escape the maze.

Input
There are multiple test cases. The first line of the input contains an integer , indicating the number of test cases. For each test case:

The first line contains two integers and (, ), indicating the number of grids in the maze, and the index of the starting grid.

The second line contains a string () consisting of characters ‘L’ and ‘R’. The -th character of indicates the character in the -th grid.

It is guaranteed that the sum of over all test cases will not exceed .

Output
For each test case output one line containing one integer, indicating the minimum number of grids BaoBao has to change to escape the maze.

Sample Input
3
3 2
LRL
10 4
RRRRRRRLLR
7 4
RLLRLLR
Sample Output
0
2
1
Hint
For the first sample test case, BaoBao doesn’t have to change any character and can escape from the 3rd grid. So the answer is 0.

For the second sample test case, BaoBao can change to ‘R’ and to ‘R’ and escape from the 10th grid. So the answer is 2.

For the third sample test case, BaoBao can change to ‘L’ and escape from the 1st grid. So the answer is 1.

题意:走到最左边1或者最右边n视作逃脱成功。地图上的L是向左走,R是向右走。你可以用1花费更改地图上的L、R;求逃脱的最小花费。

分析:向左走把R更新为L,向右走反之。注意最左端和最右端的点是不必考虑的。

#include <iostream>
#include <string.h>
#include <stdio.h>
#include <algorithm>

using namespace std;
const int maxn = 1e5+55;
int main()
{
    int T;
    scanf("%d",&T);
    char s[maxn];
    while(T--){
        int n,m;
        scanf("%d %d",&n,&m);
        scanf("%s",s);
        int now=m;
        int ci=0;
        /*for(int i=0;i<=n-1;i++){
            if(s[i]=='R'){
                now++;
            }else{
                now--;
            }
            if(now>n) {
                    ci++;
                    now=n-1;
            }
            if(now<1) {
                now=2;
                ci++;
            }
        }*/


        int ans=0,ans1=0;
        for(int i=1;i<m;i++)
        {
            if(s[i]=='R')
                ans++;
        }
        for(int i=m-1;i<n-1;i++)
        {
            if(s[i]=='L')
                ans1++;
        }

        printf("%d\n",min(ans,ans1));
    }

    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值