The 18th Zhejiang University Programming Contest Sponsored by TuSimple - C Mergeable Stack【链表】

Mergeable Stack
Time Limit: 2 Seconds Memory Limit: 65536 KB
Given initially empty stacks, there are three types of operations:

1 s v: Push the value onto the top of the -th stack.

2 s: Pop the topmost value out of the -th stack, and print that value. If the -th stack is empty, pop nothing and print “EMPTY” (without quotes) instead.

3 s t: Move every element in the -th stack onto the top of the -th stack in order.

Precisely speaking, denote the original size of the -th stack by , and the original size of the -th stack by . Denote the original elements in the -th stack from bottom to top by , and the original elements in the -th stack from bottom to top by .

After this operation, the -th stack is emptied, and the elements in the -th stack from bottom to top becomes . Of course, if , this operation actually does nothing.

There are operations in total. Please finish these operations in the input order and print the answer for every operation of the second type.

Input
There are multiple test cases. The first line of the input contains an integer , indicating the number of test cases. For each test case:

The first line contains two integers and (), indicating the number of stacks and the number of operations.

The first integer of the following lines will be (), indicating the type of operation.

If , two integers and (, ) follow, indicating an operation of the first type.
If , one integer () follows, indicating an operation of the second type.
If , two integers and (, ) follow, indicating an operation of the third type.
It’s guaranteed that neither the sum of nor the sum of over all test cases will exceed .

Output
For each operation of the second type output one line, indicating the answer.

Sample Input
2
2 15
1 1 10
1 1 11
1 2 12
1 2 13
3 1 2
1 2 14
2 1
2 1
2 1
2 1
2 1
3 2 1
2 2
2 2
2 2
3 7
3 1 2
3 1 3
3 2 1
2 1
2 2
2 3
2 3
Sample Output
13
12
11
10
EMPTY
14
EMPTY
EMPTY
EMPTY
EMPTY
EMPTY
EMPTY

模拟栈的操作,用链表非常的合适。
WA点:当s栈里没有元素的时候,加入t栈后要记得更新栈底、栈顶,并且清空t栈。

#include<iostream>
#include<cstring>
#include<cstdio>
#include<algorithm>
#include<map>
#include<set>
#include<queue>
#include<stack>
using namespace std;
#define ll long long int
#define INF 0x3f3f3f3f
const int maxn = 3e5 + 10;
int head[maxn]; int sz = 0;
int wb[maxn];
struct node {
    int nx; int u, v;
}a[maxn];
void add(int u, int v) {
    sz++;
    a[sz].v = v;
    a[sz].u = u;
    int tmp = head[u];
    head[u] = sz;
    a[sz].nx = tmp;
}
int main()
{
    int T;
    scanf("%d", &T);
    while (T--) {
        memset(wb, -1, sizeof wb);
        memset(head, -1, sizeof head); sz = 0;
        int n, q;
        scanf("%d%d", &n, &q);
        for (int k = 1; k <= q; k++) {
            int op;
            scanf("%d", &op);
            if (op == 1) {
                int s, v;
                scanf("%d%d", &s, &v);
                add(s, v);
                if (wb[s] == -1) wb[s] = sz;

            }
            else if (op == 2) {
                int s;
                scanf("%d", &s); 
                if (head[s] == -1) {
                    printf("EMPTY\n");
                }
                else {
                    printf("%d\n", a[head[s]].v);
                }
                if (head[s]!=-1)
                {
                    int tmp = a[head[s]].nx;
                    head[s] = tmp;
                    if (tmp == -1) wb[s] = -1;
                }
            }
            else {
                int s, t;
                scanf("%d%d", &s, &t); 
                if (head[t] != -1) {
                    if (head[s] != -1) {
                        a[wb[t]].nx = head[s];
                        head[s] = head[t];
                        head[t] = -1;
                        wb[t] = -1;
                    }
                    else {
                        a[wb[t]].nx = head[s];
                        head[s] = head[t];
                        wb[s] = wb[t];
                        head[t] = -1;
                        wb[t] = -1;
                    }
                }
            }
        }
    }
    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值