2018 Multi-University Training Contest 1 1011 Time Zone 【模拟】

Time Zone
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 5204 Accepted Submission(s): 878

Problem Description

Chiaki often participates in international competitive programming contests. The time zone becomes a big problem.
Given a time in Beijing time (UTC +8), Chiaki would like to know the time in another time zone s.

Input

There are multiple test cases. The first line of input contains an integer T (1≤T≤106), indicating the number of test cases. For each test case:
The first line contains two integers a, b (0≤a≤23,0≤b≤59) and a string s in the format of “UTC+X”, “UTC-X”, “UTC+X.Y”, or “UTC-X.Y” (0≤X,X.Y≤14,0≤Y≤9).

Output

For each test, output the time in the format of hh:mm (24-hour clock).

Sample Input

3
11 11 UTC+8
11 12 UTC+9
11 23 UTC+0

Sample Output

11:11
12:12
03:23

#include <iostream>
#include <stdio.h>
#include <string.h>
#include <algorithm>
#include <string>
#include <map>
using namespace std;
#define LL long long
const int maxn = 5000+3;
const double eps = 1e-8;

void check(int &hh,int &ff) {
    while(ff>=60) {
        ff-=60;
        hh+=1;
    }
    while(ff<0) {
        ff+=60;
        hh-=1;
    }
    while(hh>=24) {
        hh-=24;
    }
    while(hh<0) {
        hh+=24;
    }
}

int main() {
    int T;
    scanf("%d",&T);
    while(T--) {
        int hh,ff;
        scanf("%d%d",&hh,&ff);
        getchar();
        getchar();
        getchar();
        getchar();
        char f=getchar();
        int a;
        scanf("%d",&a);
        if(f=='-') a=-a;
        char c=getchar();
        if(c=='\n') {

            ff+=(a-8)*60;
        } else {
            int b;
            scanf("%d",&b);
            if(f=='-') b=-b;
            ff+=60*a+6*b-8*60;
        }
        check(hh,ff);
        printf("%02d:%02d\n",hh,ff);

    }


    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值