UVa 208 Firetruck 消防车

    The Center City fire department collaborates with the transportation department to maintain mapsof the city which reflects the current status of the city streets. 

   On any given day, several streets areclosed for repairs or construction. Firefighters need to be able to select routes from the firestations tofires that do not use closed streets.Central City is divided into non-overlapping fire districts, each containing a single firestation. Whena fire is reported, a central dispatcher alerts the firestation of the district where the fire is located andgives a list of possible routes from the firestation to the fire. You must write a program that the centraldispatcher can use to generate routes from the district firestations to the fires.

Input:

The city has a separate map for each fire district. Streetcorners of each map are identified by positiveintegers less than 21, with the firestation always on corner #1. The input file contains several test casesrepresenting different fires in different districts.

• The first line of a test case consists of a single integer which is the number of the streetcornerclosest to the fire.

• The next several lines consist of pairs of positive integers separated by blanks which are theadjacent streetcorners of open streets. (For example, if the pair 4 7 is on a line in the file, thenthe street between streetcorners 4 and 7 is open. There are no other streetcorners between 4 and7 on that section of the street.)

• The final line of each test case consists of a pair of 0’s.

Output:

For each test case, your output must identify the case by number (‘CASE 1:’, ‘CASE 2:’, etc). It mustlist each route on a separate line, with the streetcorners written in the order in which they appear onthe route. And it must give the total number routes from firestation to the fire. Include only routeswhich do not pass through any streetcorner more than once. (For obvious reasons, the firedepartment doesn’t want its trucks driving around in circles.)Output from separate cases must appear on separate lines.

Sample Input:

6

1 2

1 3

3 4

3 5

4 6

5 6

2 3

2 4

0 0

4

2 3

3 4

5 1

1 6

7 8

8 9

2 5

5 7

3 1

1 8

4 6

6 9

0 0

Sample Output:

CASE 1:

1 2 3 4 6

1 2 3 5 6

1 2 4 3 5 6

1 2 4 6

1 3 2 4 61 3 4 61 3 5 6

There are 7 routes from the firestation to streetcorner 6.

CASE 2:

1 3 2 5 7 8 9 6 4

1 3 41 5 2 3 4

1 5 7 8 9 6 4

1 6 4

1 6 9 8 7 5 2 3 4

1 8 7 5 2 3 4

1 8 9 6 4

There are 8 routes from the firestation to streetcorner 4.


老师说我们之前的题目都是水题。。。真正的搜索题要考虑各种各样子的减枝,然后第一题我就想了好久,最后还是去网上学习了各路大神的写法才ac的,路还很长啊。

#include <cstdio>
#include <iostream>
#include <map>
#include <cstring>
#include <algorithm>
using namespace std;

int fd[25][25];
int ff[25][25];
int n,m,num,zs[25];
int pd[25];
int ans[25];
//
void print(int x);
void dfs(int x)                                    //递归模板
{
    if(ans[x-1]==n){print(x);num++;}
    else
    {
        for(int i=1;i<m;i++)
        {
            //cout<<zs[i]<<endl;
            if(pd[zs[i]]==0&&fd[ans[x-1]][zs[i]]==1&&ff[zs[i]][n])   //ff在这里用于判断这个点是否可以到终点
            {
                pd[zs[i]]=1;
                ans[x]=zs[i];
                dfs(x+1);
                pd[zs[i]]=0;
            }
        }
    }
}

int main()
{
    int ca=1;
    while(scanf("%d",&n)==1)
    {
        map<int ,int >Q;
        map<int,int>p;

        m=0,num=0;
        //p.clear();
        memset(ff,0,sizeof(ff));      //清0;
        memset(zs,0,sizeof(zs));
        memset(fd,0,sizeof(fd));
        memset(pd,0,sizeof(pd));
        memset(ans,0,sizeof(ans));

        int a,b;
        while(scanf("%d%d",&a,&b)==2&&a&&b)
        {
            fd[a][b]=1;                            //将相互连接的两个节点标记
            fd[b][a]=1;
            ff[a][b]=1;                            //你们猜我为什么要标记两次
            ff[b][a]=1;
            if(!Q.count(a)){Q[a]=1;zs[m++]=a;}     //用map判断该数字是否出现过,没出现过就要存入数组
            if(!Q.count(b)){Q[b]=1;zs[m++]=b;}

        }
        sort(zs,zs+m);
        for(int i=0;i<m;i++)
            for(int j=0;j<m;j++)
                for(int r=0;r<m;r++)
                {
                    if(ff[zs[j]][zs[i]]&&ff[zs[i]][zs[r]]) ff[zs[j]][zs[r]]=1;     //用来判断这个点最终能否到达终点(判断在上面一行实现)
                }

        printf("CASE %d:\n",ca++);
        ans[0]=1;
        dfs(1);
        printf("There are %d routes from the firestation to streetcorner %d.\n",num,n);

    }
    return 0;
}

void print(int x)                                               //输出函数
{
    for(int i=0;i<x-1;i++)
        printf("%d ",ans[i]);
        printf("%d\n",ans[x-1]);
        //cout<<endl;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值