[回溯&&剪枝]Firetruck UVA208



 Firetruck 

The Center City fire department collaborates with the transportation department to maintain maps of the city which reflects the current status of the city streets. On any given day, several streets are closed for repairs or construction. Firefighters need to be able to select routes from the firestations to fires that do not use closed streets.

Central City is divided into non-overlapping fire districts, each containing a single firestation. When a fire is reported, a central dispatcher alerts the firestation of the district where the fire is located and gives a list of possible routes from the firestation to the fire. You must write a program that the central dispatcher can use to generate routes from the district firestations to the fires.

Input

The city has a separate map for each fire district. Streetcorners of each map are identified by positive integers less than 21, with the firestation always on corner #1. The input file contains several test cases representing different fires in different districts.

  • The first line of a test case consists of a single integer which is the number of the streetcorner closest to the fire.
  • The next several lines consist of pairs of positive integers separated by blanks which are the adjacent streetcorners of open streets. (For example, if the pair 4 7 is on a line in the file, then the street between streetcorners 4 and 7 is open. There are no other streetcorners between 4 and 7 on that section of the street.)
  • The final line of each test case consists of a pair of 0's.

Output

For each test case, your output must identify the case by number (CASE #1CASE #2, etc). It must list each route on a separate line, with the streetcorners written in the order in which they appear on the route. And it must give the total number routes from firestation to the fire. Include only routes which do not pass through any streetcorner more than once. (For obvious reasons, the fire department doesn't want its trucks driving around in circles.)

Output from separate cases must appear on separate lines.

The following sample input and corresponding correct output represents two test cases.

Sample Input

6
1 2
1 3
3 4
3 5
4 6
5 6
2 3
2 4
0 0
4
2 3
3 4
5 1
1 6
7 8
8 9
2 5
5 7
3 1
1 8
4 6
6 9
0 0

Sample Output

CASE 1:
1 2 3 4 6
1 2 3 5 6
1 2 4 3 5 6
1 2 4 6
1 3 2 4 6
1 3 4 6
1 3 5 6
There are 7 routes from the firestation to streetcorner 6.
CASE 2:
1 3 2 5 7 8 9 6 4
1 3 4
1 5 2 3 4
1 5 7 8 9 6 4
1 6 4
1 6 9 8 7 5 2 3 4
1 8 7 5 2 3 4
1 8 9 6 4
There are 8 routes from the firestation to streetcorner 4.


题意:城市某个地方发生火灾,求消防队到该点可能的所有路径(有的街道需要修理不能经过)及总路径数。

这是一道典型的搜索回溯题目,首先有21个结点,直接回溯搜索肯定超时,我一开始就是直接回溯,TLE,然后必须剪枝,我想到了用并查集,在目的地连通的子图中回溯查找,不连通的话可以直接忽略。


#include<iostream>
#include<cstring>
#include<vector>

using namespace std;

int grid[25][25];
int vis[25],bin[25];
vector<int> st;
int num,m,n;

int findx(int t)
{
    int r=t;
    while(bin[r]!=r)
    {
        r=bin[r];
    }
    return r;
}

void mergex(int x,int y)
{
    int fx,fy;
    fx=findx(x),fy=findx(y);
    if(fx!=fy) bin[fy]=fx;
}

void dfs(int pos)
{
    int i,j;
    if(pos==n)
    {
        num++;
        for(i=0;i<st.size()-1;i++)
        {
            cout<<st[i]<<" ";
        }
        cout<<st[i]<<endl;
        return;
    }
    for(i=2;i<=m;i++)
    {
        if(grid[i][pos]&&vis[i]==0&&bin[i]==bin[n])
        {
            vis[i]=1;
            st.push_back(i);
            dfs(i);
            vis[i]=0;
            st.pop_back();
        }
    }
}

int main()
{
    int t=0;
    while(cin>>n)
    {
        int x,y,i,j;
        memset(grid,0,sizeof(grid));
        memset(vis,0,sizeof(vis));
        m=0;
        for(i=1;i<=24;i++)
        {
            bin[i]=i;
        }
        while(cin>>x>>y&&(x!=0||y!=0))
        {
            grid[x][y]=grid[y][x]=1;
            mergex(x,y);
            if(max(x,y)>m) m=max(x,y);
        }
        st.clear();
        cout<<"CASE "<<++t<<":"<<endl;
        for(i=1;i<=m;i++)
        {
            bin[i]=findx(i);
            //cout<<bin[i]<<endl;
        }
        num=0;
        vis[1]=1;
        st.push_back(1);
        dfs(1);
        cout<<"There are "<<num<<" routes from the firestation to streetcorner "<<n<<"."<<endl;
    }
    return 0;
}


  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值