uva 1149 Bin Packing(贪心)

A set of n 1-dimensional items have to be packed in identical bins. All bins have exactly the samelength l and each item i has length li ≤ l. We look for a minimal number of bins q such that• each bin contains at most 2 items,• each item is packed in one of the q bins,• the sum of the lengths of the items packed in a bin does not exceed l.You are requested, given the integer values n, l, l1, . . . , ln, to compute the optimal number of binsq.InputThe input begins with a single positive integer on a line by itself indicating the number of the casesfollowing, each of them as described below. This line is followed by a blank line, and there is also ablank line between two consecutive inputs.The first line of the input file contains the number of items n (1 ≤ n ≤ 105). The second linecontains one integer that corresponds to the bin length l ≤ 10000. We then have n lines containing oneinteger value that represents the length of the items.OutputFor each test case, your program has to write the minimal number of bins required to pack all items.The outputs of two consecutive cases will be separated by a blank line.Note: The sample instance and an optimal solution is shown in the figure below. Items are numberedfrom 1 to 10 according to the input order.


Sample Input

1

10

80

70

15

30

35

10

80

20

35

10

30

Sample Output

6


很基础的贪心题目,从最大的开始装就好了

#include <cstring>
#include <iostream>
#include <algorithm>
using namespace std;
int w[100010];
int main()
{
    //freopen("out.txt","w",stdout);
    int t;
    cin>>t;
    while(t--)
    {
        int L,m,ans=0;
        cin>>L>>m;
        for(int i=0;i<L;i++)
        {
            cin>>w[i];
        }
        sort(w,w+L);
        int l=0,r=L-1;
        while(l<r)
        {
            if(w[r]+w[l]>m){ans++;r--;}
            else {ans++;r--;l++;}
        }
        if(r==l)ans++;
        cout<<ans<<endl;
        if(t!=0)cout<<endl;

    }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值