UVA 1149 bin packing (贪心)

A set of n 1-dimensional items have to be packed in identical bins. All bins have exactly the same length l and each item i has length li<=l . We look for a minimal number of bins q such that 
  • each bin contains at most 2 items, 
  • each item is packed in one of the q bins, 
  • the sum of the lengths of the items packed in a bin does not exceed l . 

You are requested, given the integer values n , l , l1 , ..., ln , to compute the optimal number of bins q . 

Input 

The first line of the input contains the number of items n (1<=n<=10 5) . The second line contains one integer that corresponds to the bin length l<=10000 . We then have n lines containing one integer value that represents the length of the items. 

Output 

Your program has to write the minimal number of bins required to pack all items. 

Sample Input 

10
80
70
15
30
35
10
80
20
35
10
30

Sample Output 

6

一.分析

二.代码

//
//  main.cpp
//  Uva1149
//
//  Created by 张嘉韬 on 16/7/17.
//  Copyright © 2016年 张嘉韬. All rights reserved.
//

#include <iostream>
#include <cstring>
#include <algorithm>
using namespace std;
void print (int *l,int n)
{
    for(int i=0;i<n;i++)
    {
        cout<<l[i]<<" ";
    }
}
int main(int argc, const char * argv[]) {
    //freopen("/Users/zhangjiatao/Documents/暑期训练/input.txt","r",stdin);
    int n,L,l[100010],counter;
    counter=0;
    cin>>n>>L;
    for(int i=0;i<n;i++) cin>>l[i];
    sort(l+0,l+n);
    //print(l,n);
    int left,right;
    left=0,right=n-1;
    while(left<=right)
    {
        if(l[left]+l[right]<=L)
        {
            left++;
            right--;
        }
        else right--;
        counter++;
    }
    cout<<counter<<endl;
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值