HDU-2689 Sort it(树状数组求逆序数)

                                     Sort it

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 6438    Accepted Submission(s): 4323

Problem Description

You want to processe a sequence of n distinct integers by swapping two adjacent sequence elements until the sequence is sorted in ascending order. Then how many times it need.
For example, 1 2 3 5 4, we only need one operation : swap 5 and 4.

Input

The input consists of a number of test cases. Each case consists of two lines: the first line contains a positive integer n (n <= 1000); the next line contains a permutation of the n integers from 1 to n.

Output

For each case, output the minimum times need to sort it in ascending order on a single line.

Sample Input

3

1 2 3

4

4 3 2 1

Sample Output

0

6

 

#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
using namespace std;
const int Maxn=100005;

struct no{int v,i;}t[Maxn];
int a[Maxn],ls[Maxn],c[Maxn],n;
int lowbit(int x){return x&-x;};
bool cmp(no x,no y){return x.v<y.v;}

void update(int x,int num)
{
    for(int i=x;i<=n;i+=lowbit(i))
        c[i]+=num;
}

int getsum(int x)
{
    int sum=0;
    for(int i=x;i>=1;i-=lowbit(i))
        sum+=c[i];
    return sum;
}

int main()
{
    while(~scanf("%d",&n))
    {
        long long ans=0;
        for(int i=1;i<=n;i++)
        {
            scanf("%d",&t[i].v);
            t[i].i=i;
        }
        sort(t+1,t+n+1,cmp);
        for(int i=1;i<=n;i++)
            ls[t[i].i]=i;
        memset(c,0,sizeof(c));
        for(int i=1;i<=n;i++)
        {
            update(ls[i],1);
            ans+=i-getsum(ls[i]);
        }
        printf("%lld\n",ans);
    }
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值