Sticks
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 15256 Accepted Submission(s): 4695
Problem Description
George took sticks of the same length and cut them randomly until all parts became at most 50 units long. Now he wants to return sticks to the original state, but he forgot how many sticks he had originally and how long they were originally. Please help him and design a program which computes the smallest possible original length of those sticks. All lengths expressed in units are integers greater than zero.
Input
The input contains blocks of 2 lines. The first line contains the number of sticks parts after cutting, there are at most 64 sticks. The second line contains the lengths of those parts separated by the space. The last line of the file contains zero.
Output
The output file contains the smallest possible length of original sticks, one per line.
Sample Input
9
5 2 1 5 2 1 5 2 1
4
1 2 3 4
0
Sample Output
6
5
#include<cstdio>
#include<cstring>
#include<cstdlib>
#include<iostream>
#include<algorithm>
using namespace std;
const int Maxn=100;
int a[Maxn],vis[Maxn],sum,val,n;
bool cmp(int x,int y){return x>y;}
bool dfs(int i,int left,int tol)
{
int j;
if(left==0)
{
tol-=val;
if(tol==val) return 1;
if(tol< val) return 0;
for(j=0;j<n;j++)
if(vis[j]==0)
break;
vis[j]=1;
if(dfs(j+1,val-a[j],tol))
return 1;
vis[j]=0;
tol+=val;
return 0;
}
else
{
for(j=i;j<n;j++)
{
if(a[j]>left||vis[j]) continue;
if(a[j]==a[j-1]&&!vis[j-1]) continue;
vis[j]=1;
if(dfs(j+1,left-a[j],tol))
return 1;
vis[j]=0;
}
return 0;
}
return 0;
}
int Find()
{
int k=0;
for(val=a[0];val<=sum/2;val++)
{
if(sum%val==0)
{
k=dfs(0,val,sum);
if(k!=0)
return val;
}
}
if(k==0)
return sum;
}
int main()
{
while(~scanf("%d",&n)&&n)
{
sum=0;
memset(vis,0,sizeof(vis));
for(int i=0;i<n;i++)
{
scanf("%d",a+i);
sum+=a[i];
}
sort(a,a+n,cmp);
printf("%d\n",Find());
}
return 0;
}