http://acm.hust.edu.cn/vjudge/contest/view.action?cid=27048#problem/B
http://poj.org/problem?id=1579
Function Run Fun
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 14694 Accepted: 7599
Description
We all love recursion! Don't we?
Consider a three-parameter recursive function w(a, b, c):
if a <= 0 or b <= 0 or c <= 0, then w(a, b, c) returns:
1
if a > 20 or b > 20 or c > 20, then w(a, b, c) returns:
w(20, 20, 20)
if a < b and b < c, then w(a, b, c) returns:
w(a, b, c-1) + w(a, b-1, c-1) - w(a, b-1, c)
otherwise it returns:
w(a-1, b, c) + w(a-1, b-1, c) + w(a-1, b, c-1) - w(a-1, b-1, c-1)
This is an easy function to implement. The problem is, if implemented directly, for moderate values of a, b and c (for example, a = 15, b = 15, c = 15), the program takes hours to run because of the massive recursion.
Input
The input for your program will be a series of integer triples, one per line, until the end-of-file flag of -1 -1 -1. Using the above technique, you are to calculate w(a, b, c) efficiently and print the result.
Output
Print the value for w(a,b,c) for each triple.
Sample Input
1 1 1
2 2 2
10 4 6
50 50 50
-1 7 18
-1 -1 -1
Sample Output
w(1, 1, 1) = 2
w(2, 2, 2) = 4
w(10, 4, 6) = 523
w(50, 50, 50) = 1048576
w(-1, 7, 18) = 1
Source
Pacific Northwest 1999
解析:
根据自变量范围,打表即可
Accepted 208K 0MS C++ 952B 2013-07-24 09:34:34
*/
#include<stdio.h>
#include<string.h>
#include <iostream>
using namespace std;
const int N=22;
int w[N][N][N];
void init()
{
int i,j,k;
memset(w,0,sizeof(w));
for(i=0;i<=21;i++)
{
for(j=0;j<=21;j++)
{
for(k=0;k<=21;k++)
{ if(i<=0||j<=0||k<=0)
w[i][j][k]=1;
else if(i>20||j>20||k>20)
w[i][j][k]=w[20][20][20];
else if(i<j&&j<k)
w[i][j][k]=w[i][j][k-1]+w[i][j-1][k-1]-w[i][j-1][k];
else
w[i][j][k]=w[i-1][j][k]+w[i-1][j-1][k]+w[i-1][j][k-1]-w[i-1][j-1][k-1];
}
}
}
}
int main()
{
init();
int a,b,c,ans;
while(scanf("%d%d%d",&a,&b,&c)!=EOF)
{
if(a==-1&&b==-1&&c==-1)
break;
if(a<=0||c<=0||b<=0)
ans=1;
else if(a>20||b>20||c>20)
ans=w[20][20][20];
else
ans=w[a][b][c];
printf("w(%d, %d, %d) = %d\n",a,b,c,ans);
//printf("%d\n",w[20][20][20]);
}
return 0;
}