http://acm.hdu.edu.cn/showproblem.php?pid=1269
迷宫城堡
Problem Description
为了训练小希的方向感,Gardon建立了一座大城堡,里面有N个房间(N<=10000)和M条通道(M<=100000),每个通道都是单向的,就是说若称某通道连通了A房间和B房间,只说明可以通过这个通道由A房间到达B房间,但并不说明通过它可以由B房间到达A房间。Gardon需要请你写个程序确认一下是否任意两个房间都是相互连通的,即:对于任意的i和j,至少存在一条路径可以从房间i到房间j,也存在一条路径可以从房间j到房间i。
Input
输入包含多组数据,输入的第一行有两个数:N和M,接下来的M行每行有两个数a和b,表示了一条通道可以从A房间来到B房间。文件最后以两个0结束。
Output
对于输入的每组数据,如果任意两个房间都是相互连接的,输出"Yes",否则输出"No"。
Sample Input
3 3
1 2
2 3
3 1
3 3
1 2
2 3
3 2
0 0
Sample Output
Yes
No
Author
Gardon
Source
HDU 2006-4 Programming Contest
Recommend
lxj
解析:
题意:
给出一个有向图,n个节点,m条边,问图上任意两点是否可达
思路:裸的强连通分量
已知任意一个强连通分量的任意两可达。故在求强连通分量时记录分量所含节点数,然后判断是否存在强连通分量的节点数大于等于n
3556 KB 31 ms C++ 1417 B
*/
#include<stdio.h>
#include<string.h>
#include<stdlib.h>
#include<queue>
#include <iostream>
using namespace std;
const int maxn=100000+10;
int pre[maxn],low[maxn],scc[maxn];
int t,dfsn,sccn,top;
int head[maxn],num[maxn],q[maxn];
struct node{
int u;
int next;
int v;
}edge[maxn];
int min(int a,int b)
{
return a<b? a:b;
}
void init()
{
memset(head,-1,sizeof(head));
memset(pre,0,sizeof(pre));
memset(low,0,sizeof(low));
memset(scc,0,sizeof(scc));
memset(num,0,sizeof(num));
top=t=sccn=dfsn=0;
}
void addedge(int u,int v)//建立邻接表
{
edge[t].u=u;
edge[t].v=v;
edge[t].next=head[u];
head[u]=t++;
}
void dfs(int u)//求强连通分量
{
pre[u]=low[u]=++dfsn;
q[top++]=u;
for(int i=head[u];i!=-1;i=edge[i].next)
{
int v=edge[i].v;
if(!pre[v])
{
dfs(v);
low[u]=min(low[u],low[v]);
}
else if(!scc[v])
{
low[u]=min(low[u],pre[v]);
}
}
if(low[u]==pre[u])
{
sccn++;
for(;;)
{
int x=q[--top];
scc[x]=sccn;
num[sccn]++;
if(x==u)
break;
}
}
}
int main()
{
int n,m,i;
while(scanf("%d%d",&n,&m)!=EOF)
{
if(n==0&&m==0)
break;
int u,v,t;
init();
for(i=0;i<m;i++)
{
scanf("%d%d",&u,&v);
addedge(u,v);
}
dfs(1);
int ok=0;
for(i=0;i<=sccn;i++)
{
if(num[i]>=n)
{ ok=1;
break;
}
}
if(ok)
printf("Yes\n");
else
printf("No\n");
}
//system("pause");
return 0;
}