KMP之求最大周期数


http://acmore.net:8080/contest/view.action?cid=11#problem/C
C - KMP
Time Limit:3000MS     Memory Limit:65536KB     64bit IO Format:%I64d & %I64u
Submit


Status
Description
Given two strings a and b we define a*b to be their concatenation. For example, if a = "abc" and b = "def" then a*b = "abcdef". If we think of concatenation as multiplication, exponentiation by a non-negative integer is defined in the normal way: a^0 = "" (the empty string) and a^(n+1) = a*(a^n).
Input
Each test case is a line of input representing s, a string of printable characters. The length of s will be at least 1 and will not exceed 1 million characters. A line containing a period follows the last test case.
Output
For each s you should print the largest n such that s = a^n for some string a.
Sample Input
abcd
aaaa
ababab
.
Sample Output
1
4
3
Hint
题意:就是求出最大周期数:
思路:这里运用了KMP算法,模式串自我匹配的原理计算的(详细的内容可以参考《数据结构》(C语言版))


#include<stdio.h>
#include<stdlib.h>
#include<string.h>
#include <iostream>
using namespace std;
const int maxn=1000000+10;
char w[maxn];
int p[maxn];
int m;
void kmp()
 {


           p[0]=-1;
           int j=-1;
          int i=0;
   while(w[i]!='\0')
  {
           if(j==-1||w[i]==w[j])
            {
                      i++;
                      j++;
                      p[i]=j;
            }
            else
            j=p[j];
  }
 }
 int main()
 {
           int ans;
           while(scanf("%s",w)!=EOF)
           {
           if(w[0]=='.')
           break;
           m=strlen(w);
          kmp();
          ans=m-p[m];
           if(m%ans)
            printf("1\n");
           else
           printf("%d\n",m/ans);
           }
           return 0;
 }


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值