Phone List(poj3630,字典树)

/*http://poj.org/problem?id=3630
Phone List
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 18141 Accepted: 5773
Description


Given a list of phone numbers, determine if it is consistent in the sense that no number is the prefix of another. Let's say the phone catalogue listed these numbers:


Emergency 911
Alice 97 625 999
Bob 91 12 54 26
In this case, it's not possible to call Bob, because the central would direct your call to the emergency line as soon as you had dialled the first three digits of Bob's phone number. So this list would not be consistent.


Input


The first line of input gives a single integer, 1 ≤ t ≤ 40, the number of test cases. Each test case starts with n, the number of phone numbers, on a separate line, 1 ≤ n ≤ 10000. Then follows n lines with one unique phone number on each line. A phone number is a sequence of at most ten digits.


Output


For each test case, output "YES" if the list is consistent, or "NO" otherwise.


Sample Input


2
3
911
97625999
91125426
5
113
12340
123440
12345
98346
Sample Output


NO
YES
Source


Nordic 2007
题意:问是否存在一个字符串是另一个字符串的前缀。
要点: 利用字典树的性质边构造字典树,边查找;
  注意事项:1,当建立新的节点时一定要清空空间
            2,一下出现这两种情况都应该退出
              a:自己已经是别的串的前缀了;
              b:别的串已经成了自己的前缀了
     
*/
#include<stdio.h>
#include<string.h>
#include <iostream>
using namespace std;
const int maxn=100000+10;
int trie[maxn][10];// trie[i][j]表示用来保存节点i的那个编号为j的字节点
int node[maxn];//表示当前节点的权值,当node[i]=1时形成一个字符,以节点i结尾
int cnt;
void init()
{
           cnt=1;
           memset(trie[0],0,sizeof(trie[0]));
}
int insert(char s[])//边插入,变查找
{
           int u=0;
           int len=strlen(s);
           for(int i=0;i<len;i++)
          {int v=s[i]-'0';
          if(trie[u][v]==0)  //1开辟新空间
            {memset(trie[cnt],0,sizeof(trie[cnt]));
            node[cnt]=0;
            trie[u][v]=cnt++;
            }
            u=trie[u][v];
            if(node[u]==1)//2已出现前缀
             return 1;
             if(i==len-1)
             {for(int j=0;j<10;j++)
                      if(trie[u][v]) //3成为别串的前缀
                      return 1;
             }


          }
          node[u]=1;//该串结束的标志
          return 0;


}




int main()
{
  int T,n,i;
   bool ok;
   char ch[12];
   scanf("%d",&T);
   while(T--)
  {
             init();
           ok=false;
            scanf("%d",&n);
           for( i=0;i<n;i++)
           {scanf("%s",ch);
           ok=insert(ch);
           if(ok==true) //一旦发现出现前缀退出
            break;
           }
           while(i<n-1)
           {scanf("%s",ch);
           i++;
           }


           if(ok==false)
           printf("YES\n");
           else
           printf("NO\n");
   }
   return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值