Discount(HDU 4104,求数列和子集问题)

/*http://acm.hust.edu.cn/vjudge/contest/view.action?cid=22157#problem/D
D - Discount
Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u
Submit


Status


Practice



Description




All the shops use discount to attract customers, but some shops doesn’t give direct discount on their goods, instead, they give discount only when you bought more than a certain amount of goods. Assume a shop offers a 20% off if your bill is more than 100 yuan, and with more than 500 yuan, you can get a 40% off. After you have chosen a good of 400 yuan, the best suggestion for you is to take something else to reach 500 yuan and get the 40% off.
For the customers’ convenience, the shops often offer some low-price and useful items just for reaching such a condition. But there are still many customers complain that they can’t reach exactly the budget they want. So, the manager wants to know, with the items they offer, what is the minimum budget that cannot be reached. In addition, although the items are very useful, no one wants to buy the same thing twice.


Input
The input consists several testcases.
The first line contains one integer N (1 <= N <= 1000), the number of items available.
The second line contains N integers Pi (0 <= Pi <= 10000), represent the ith item’s price.




Output
Print one integer, the minimum budget that cannot be reached.


Sample Input
4
1 2 3 4


Sample Output
11
 题意:这道题卡就卡在题意理解上了,看了半天还是没有把题意弄懂,看了挺多人AC,就应该知道这题不难,事实证明很简单
 总的意思就是给你一列数列,根据其和的子集,求出一个最小的数不在其子集中;例如:输入
                                                                              3
                                                                              3 4 7
                                                                              则有其和的结果:3
                                                                                              4
                                                                                              7
                                                                                              3+7=10;
                                                                                              4+7=11;
                                                                                              3+4+7=14
                                                                                              故结果为1;
 其实不难发现,如果数列中最小的如果大于1的话,最终结果自然就是1(因为无论怎么做,始终得不到最小值为1的预算)                                                                                             
*/
i#nclude<stdio.h>
#include<algorithm>
#include<string.h>
#include <iostream>
using namespace std;
const int maxn=1000+10;
int p[maxn];
int main()
{int i,n,sum;
 while(scanf("%d",&n)!=EOF)
  {


           for(i=0;i<n;i++)
           {scanf("%d",&p[i]);
           }
           sort(p,p+n);
           sum=0;
           for(i=0;i<n;i++)
           {
           if(sum<(p[i]-1))//这说明当前的sum至少比p[i]小2,得不到sum+1 ,退出
             break;
             sum+=p[i];
           }
           printf("%d\n",sum+1);
}
return 0;


}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值