hdu 4104 Discount (思维 数学归纳法)

Discount

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1072    Accepted Submission(s): 645


Problem Description

All the shops use discount to attract customers, but some shops doesn’t give direct discount on their goods, instead, they give discount only when you bought more than a certain amount of goods. Assume a shop offers a 20% off if your bill is more than 100 yuan, and with more than 500 yuan, you can get a 40% off. After you have chosen a good of 400 yuan, the best suggestion for you is to take something else to reach 500 yuan and get the 40% off.
For the customers’ convenience, the shops often offer some low-price and useful items just for reaching such a condition. But there are still many customers complain that they can’t reach exactly the budget they want. So, the manager wants to know, with the items they offer, what is the minimum budget that cannot be reached. In addition, although the items are very useful, no one wants to buy the same thing twice.
 

Input
The input consists several testcases.
The first line contains one integer N (1 <= N <= 1000), the number of items available.
The second line contains N integers P i (0 <= P i <= 10000), represent the ith item’s price.

 

Output
Print one integer, the minimum budget that cannot be reached.
 

Sample Input
  
  
4 1 2 3 4
 

Sample Output
  
  
11
 

Source
 

Recommend
lcy


思路:
先将a[i]排序,假设前i个元素,已经能表示1~sum之间的数了,那么a[i+1]加进来之后,
1.如果a[i+1]>sum+1,那么sum+1肯定表示不了,ans=sum+1。
2.如果a[i+1]<=sum+1,那么1~sum+a[i+1]就都能表示了,产生新的sum,进行下一循环。

ps:懂了之后就是满简单的一道思维题了,可是比赛时就是想不到,思维能力太烂了。

代码:
#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
#include <string>
#include <map>
#include <stack>
#include <vector>
#include <set>
#include <queue>
//#pragma comment (linker,"/STACK:102400000,102400000")
#define maxn 1005
#define mod 1000000007
#define INF 0x3f3f3f3f
using namespace std;

typedef long long ll;
int n,m,ans,cnt,flag,sum;
int a[maxn];
int dp[maxn];

void solve()
{
    int i,j,u,v;
    sum=0;
    for(i=1;i<=n;i++)
    {
        if(a[i]>sum+1)
        {
            ans=sum+1;
            return ;
        }
        sum+=a[i];
    }
    ans=sum+1;
}
int main()
{
    int i,j;
    while(~scanf("%d",&n))
    {
        for(i=1;i<=n;i++)
        {
            scanf("%d",&a[i]);
        }
        sort(a+1,a+n+1);
        solve();
        printf("%d\n",ans);
    }
    return 0;
}




 
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值