Parencodings(poj1068简单模拟)



/*http://acm.hust.edu.cn/vjudge/contest/view.action?cid=27454#problem/B
B - Parencodings
Time Limit:1000MS     Memory Limit:10000KB     64bit IO Format:%I64d & %I64u
Submit
 
Status
 
Practice
 
POJ 1068
Description
Let S = s1 s2...s2n be a well-formed string of parentheses. S can be encoded in two different ways: 
q By an integer sequence P = p1 p2...pn where pi is the number of left parentheses before the ith right parenthesis in S (P-sequence). 
q By an integer sequence W = w1 w2...wn where for each right parenthesis, say a in S, we associate an integer which is the number of right parentheses counting from the matched left parenthesis of a up to a. (W-sequence). 


Following is an example of the above encodings: 


S (((()()())))


P-sequence    4 5 6666


W-sequence    1 1 1456




Write a program to convert P-sequence of a well-formed string to the W-sequence of the same string. 
Input
The first line of the input contains a single integer t (1 <= t <= 10), the number of test cases, followed by the input data for each test case. The first line of each test case is an integer n (1 <= n <= 20), and the second line is the P-sequence of a well-formed string. It contains n positive integers, separated with blanks, representing the P-sequence.
Output
The output file consists of exactly t lines corresponding to test cases. For each test case, the output line should contain n integers describing the W-sequence of the string corresponding to its given P-sequence.
Sample Input
2
6
4 5 6 6 6 6

4 6 6 6 6 8 9 9 9
Sample Output
解析:
题意:
给出一组数,第i个数表示第i个右括号前面有几个左括号
要求输出的一组数据,表示每个右括号与它前面的第几个左括号匹配
思路:
1.建模:根据所给出数据构造一组数据用1表示右括号,0表示左括号.s[i]表示第i个值是哪种括号
2,查找:从每个右括号向前找出未被匹配的左括号,匹配完毕要做标记
Memory Time Language Length Submit Time
164 KB 0 ms C++ 641 B 2013-07-29 09:25:05
*/
#include<stdio.h>
#include<string.h>
#include <iostream>
using namespace std;
int s[100],q[25],w[25];
int main()
{  int T,n,q1,i,j,k;
scanf("%d",&T);
while(T--)
{   memset(s,0,sizeof(s));
	scanf("%d",&n);
	scanf("%d",&q[1]);
	q1=q[1];
	s[q1+1]=1;
	k=q1+1;
	for(i=2;i<=n;i++)
	{
		scanf("%d",&q[i]);
		k+=q[i]-q1+1;
		s[k]=1;
		q1=q[i];
	}
	memset(w,0,sizeof(w));
	for(i=1;i<=n;i++)
	 {k=0;
	 	for(j=q[i]+i-1;j>=1;j--)
	 	{
	 		if(s[j]==0)
	 		{k++;
	 		 s[j]=-1;
	 		break;
	 		}
	 		if(s[j]==-1)
	 		k++;
	 	}
	 	w[i]=k;
	 }
	 for(i=1;i<=n;i++)
	 {printf("%d",w[i]);
	 if(i!=n)
	   printf(" ");
	   else
	   printf("\n");
	 }
}
return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值