/*
http://acm.hdu.edu.cn/showproblem.php?pid=1513
Palindrome
Time Limit: 4000/2000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 2420 Accepted Submission(s): 831
Problem Description
A palindrome is a symmetrical string, that is, a string read identically from left to right as well as from right to left. You are to write a program which, given a string, determines the minimal number of characters to be inserted into the string in order to obtain a palindrome.
As an example, by inserting 2 characters, the string "Ab3bd" can be transformed into a palindrome ("dAb3bAd" or "Adb3bdA"). However, inserting fewer than 2 characters does not produce a palindrome.
Input
Your program is to read from standard input. The first line contains one integer: the length of the input string N, 3 <= N <= 5000. The second line contains one string with length N. The string is formed from uppercase letters from 'A' to 'Z', lowercase letters from 'a' to 'z' and digits from '0' to '9'. Uppercase and lowercase letters are to be considered distinct.
Output
Your program is to write to standard output. The first line contains one integer, which is the desired minimal number.
Sample Input
5
Ab3bd
Sample Output
2
Source
IOI 2000
Recommend
linle
解析:
思路:
题意:给出一个字符串,问最少插入多少个字符可以使其变成回文字串
思路:把字符串到过来求最长公共序列
注意:由于数据比较大,这里运用了二维滚动数组,这个方法可以防止超内存
272 KB 453 ms C++ 519 B 2013-08-04 11:37:00
*/
http://acm.hdu.edu.cn/showproblem.php?pid=1513
Palindrome
Time Limit: 4000/2000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 2420 Accepted Submission(s): 831
Problem Description
A palindrome is a symmetrical string, that is, a string read identically from left to right as well as from right to left. You are to write a program which, given a string, determines the minimal number of characters to be inserted into the string in order to obtain a palindrome.
As an example, by inserting 2 characters, the string "Ab3bd" can be transformed into a palindrome ("dAb3bAd" or "Adb3bdA"). However, inserting fewer than 2 characters does not produce a palindrome.
Input
Your program is to read from standard input. The first line contains one integer: the length of the input string N, 3 <= N <= 5000. The second line contains one string with length N. The string is formed from uppercase letters from 'A' to 'Z', lowercase letters from 'a' to 'z' and digits from '0' to '9'. Uppercase and lowercase letters are to be considered distinct.
Output
Your program is to write to standard output. The first line contains one integer, which is the desired minimal number.
Sample Input
5
Ab3bd
Sample Output
2
Source
IOI 2000
Recommend
linle
解析:
思路:
题意:给出一个字符串,问最少插入多少个字符可以使其变成回文字串
思路:把字符串到过来求最长公共序列
注意:由于数据比较大,这里运用了二维滚动数组,这个方法可以防止超内存
272 KB 453 ms C++ 519 B 2013-08-04 11:37:00
*/
#include<stdio.h>
#include<string.h>
#include<algorithm>
#include <iostream>
using namespace std;
const int maxn=5000+10;
int dp[2][maxn];
char s1[maxn];
int max(int a,int b){return a>b? a:b;}
int main()
{ int i,j,n,ans;
while(scanf("%d",&n)!=EOF)
{
scanf("%s",s1);
memset(dp,0,sizeof(dp));
for(i=1;i<=n;i++)
for(j=1;j<=n;j++)
{
if(s1[i-1]==s1[n-j])
dp[i%2][j]=dp[(i-1)%2][j-1]+1;
else
dp[i%2][j]=max(dp[(i-1)%2][j],dp[i%2][j-1]);
}
ans=n-dp[n%2][n];
printf("%d\n",ans);
}
return 0;
}