HDU1513:Palindrome 【LCS】

Palindrome

Time Limit : 4000/2000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other)
Total Submission(s) : 42   Accepted Submission(s) : 8
Problem Description
A palindrome is a symmetrical string, that is, a string read identically from left to right as well as from right to left. You are to write a program which, given a string, determines the minimal number of characters to be inserted into the string in order to obtain a palindrome.

As an example, by inserting 2 characters, the string "Ab3bd" can be transformed into a palindrome ("dAb3bAd" or "Adb3bdA"). However, inserting fewer than 2 characters does not produce a palindrome.
 

Input
Your program is to read from standard input. The first line contains one integer: the length of the input string N, 3 <= N <= 5000. The second line contains one string with length N. The string is formed from uppercase letters from 'A' to 'Z', lowercase letters from 'a' to 'z' and digits from '0' to '9'. Uppercase and lowercase letters are to be considered distinct.
 

Output
Your program is to write to standard output. The first line contains one integer, which is the desired minimal number.
 

Sample Input
  
  
5 Ab3bd
 

Sample Output
  
  
2
 


题意大致是让你求出这个字符串至少加几个字符能够变成回文字符串~~由于dp数组可能要开到5000*5000导致内存超出,但是可以用到滚动数组~~对于dp来说,第一维只要有两位就够了~~~所以可以用求余的方法~~刚开始的时候一直错。。就是不知道咋回事,各种修改,最后才发现是我木有让他循环输入~~~哭

AC-code:

#include<cstdio>
#include<cstring>
#define max(a,b) (a>b?a:b)
using namespace std;
int main()
{
	int n,i,j,dp[5][5005];
	char s[5005];
	while(~scanf("%d",&n))
	{
		memset(dp,0,sizeof(dp));
		getchar();
		scanf("%s",&s);
		for(i=1;i<=n;i++)
			for(j=1;j<=n;j++)
			{
				if(s[i-1]==s[n-j])
					dp[i%5][j]=dp[(i-1)%5][j-1]+1;
				else
					dp[i%5][j]=max(dp[(i-1)%5][j],dp[i%5][j-1]);
			}
		printf("%d\n",n-dp[n%5][n]);
	}
	return 0;
}


 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值