Ignatius and the Princess I(hdu1026,带权值的bfs)

73 篇文章 0 订阅
10 篇文章 0 订阅
/*
http://acm.hdu.edu.cn/showproblem.php?pid=1026
Ignatius and the Princess I


Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 9969    Accepted Submission(s): 2989
Special Judge


Problem Description
The Princess has been abducted by the BEelzebub feng5166, our hero Ignatius has to rescue our pretty Princess. Now he gets into feng5166's castle. The castle is a large labyrinth. To make the problem simply, we assume the labyrinth is a N*M two-dimensional array which left-top corner is (0,0) and right-bottom corner is (N-1,M-1). Ignatius enters at (0,0), and the door to feng5166's room is at (N-1,M-1), that is our target. There are some monsters in the castle, if Ignatius meet them, he has to kill them. Here is some rules:


1.Ignatius can only move in four directions(up, down, left, right), one step per second. A step is defined as follow: if current position is (x,y), after a step, Ignatius can only stand on (x-1,y), (x+1,y), (x,y-1) or (x,y+1).
2.The array is marked with some characters and numbers. We define them like this:
. : The place where Ignatius can walk on.
X : The place is a trap, Ignatius should not walk on it.
n : Here is a monster with n HP(1<=n<=9), if Ignatius walk on it, it takes him n seconds to kill the monster.


Your task is to give out the path which costs minimum seconds for Ignatius to reach target position. You may assume that the start position and the target position will never be a trap, and there will never be a monster at the start position.
 


Input
The input contains several test cases. Each test case starts with a line contains two numbers N and M(2<=N<=100,2<=M<=100) which indicate the size of the labyrinth. Then a N*M two-dimensional array follows, which describe the whole labyrinth. The input is terminated by the end of file. More details in the Sample Input.
 


Output
For each test case, you should output "God please help our poor hero." if Ignatius can't reach the target position, or you should output "It takes n seconds to reach the target position, let me show you the way."(n is the minimum seconds), and tell our hero the whole path. Output a line contains "FINISH" after each test case. If there are more than one path, any one is OK in this problem. More details in the Sample Output.
 


Sample Input
5 6
.XX.1.
..X.2.
2...X.
...XX.
XXXXX.
5 6
.XX.1.
..X.2.
2...X.
...XX.
XXXXX1
5 6
.XX...
..XX1.
2...X.
...XX.
XXXXX.
 


Sample Output
It takes 13 seconds to reach the target position, let me show you the way.
1s:(0,0)->(1,0)
2s:(1,0)->(1,1)
3s:(1,1)->(2,1)
4s:(2,1)->(2,2)
5s:(2,2)->(2,3)
6s:(2,3)->(1,3)
7s:(1,3)->(1,4)
8s:FIGHT AT (1,4)
9s:FIGHT AT (1,4)
10s:(1,4)->(1,5)
11s:(1,5)->(2,5)
12s:(2,5)->(3,5)
13s:(3,5)->(4,5)
FINISH
It takes 14 seconds to reach the target position, let me show you the way.
1s:(0,0)->(1,0)
2s:(1,0)->(1,1)
3s:(1,1)->(2,1)
4s:(2,1)->(2,2)
5s:(2,2)->(2,3)
6s:(2,3)->(1,3)
7s:(1,3)->(1,4)
8s:FIGHT AT (1,4)
9s:FIGHT AT (1,4)
10s:(1,4)->(1,5)
11s:(1,5)->(2,5)
12s:(2,5)->(3,5)
13s:(3,5)->(4,5)
14s:FIGHT AT (4,5)
FINISH
God please help our poor hero.
FINISH
解析:
走迷宫,已知起点和终点,求最短时间,并且输出路径
思路:
是带权值的bfs,并且要记录路径。参考网上大神的思想敲了代码
1.首先构建一个结构体,建立优先队列,广搜,搜索时选择时间最短路
2.用递归法输出路径(如果数据比较的话,第归易超时)
Accepted 588 KB 15 ms C++ 1805 B
*/
#include<stdio.h>
#include<queue>
#include<string.h>
#include <iostream>
using namespace std;
const int maxn=100+10;
const int inf=10000000;
int m,n,ans,ok;
int dir[4][2]={{1,0},{-1,0},{0,1},{0,-1}};
struct node
{
	int x;
	int y;
	int fax;
	int fay;
	int t;
	char c;
	 bool operator<(const node&a)const
    {
        return a.t<t;//优先队列按照时间减少的顺序
    }
}p[maxn][maxn];//这里详细地记录节点上各种信息
int isok(int x,int y)//判断路径可行性
{
	if(x>=0&&x<n&&y>=0&&y<m&&p[x][y].c!='X')
	return 1;
	else
	return 0;
}
int bfs()
{  priority_queue<node>q;//建立结构体型的优先队列
   node cur;//记录当前节点
	int i,nx,ny,ns;
	p[0][0].t=0;
	q.push(p[0][0]);//入队
	while(!q.empty())
	{  cur=q.top();
	   q.pop();
	   if(cur.x==n-1&&cur.y==m-1)//一旦到达终点则输出
	    return 1;
	  for(i=0;i<4;i++)
	  {
	  	 nx=cur.x+dir[i][0];
		 ny=cur.y+dir[i][1];
	  	if(isok(nx,ny)==0)continue;
	  	if(p[nx][ny].c>='1'&&p[nx][ny].c<='9')
	  	 ns=cur.t+1+p[nx][ny].c-'0';
	  	else
	  	 ns=cur.t+1;
	  	 if(p[nx][ny].t>ns)//在当前的路径用时比较小时才更新入队进行
	  	 {
	  	 	p[nx][ny].fax=cur.x;
	  	 	p[nx][ny].fay=cur.y;
	  	 	p[nx][ny].t=ns;
	  	 	q.push(p[nx][ny]);
	  	 }
	  }
	}
	return 0;
}
void print_path(int x,int y)
{  if(x==0&&y==0)return;
	int fax=p[x][y].fax;
    int fay=p[x][y].fay;
    print_path(fax,fay);//递归输出
    int pre=p[fax][fay].t;
    int now=p[x][y].t;
    printf("%ds:(%d,%d)->(%d,%d)\n",pre+1,fax,fay,x,y);
     for(int i=pre+2;i<=now;i++)//判断是否有滞留的同时,并且且输出状态
     {printf("%ds:FIGHT AT (%d,%d)\n",i,x,y);
     }
}
int main()
{
	int i,j,ok;
	while(scanf("%d%d",&n,&m)!=EOF)
	{
		for(i=0;i<n;i++)
		 for(j=0;j<m;j++)
		 {
		 	cin>>p[i][j].c;//将其存入其中
		 	p[i][j].x=i;
		 	p[i][j].y=j;
		 	p[i][j].t=inf;
		 }
       ok=bfs();
        if(ok)
        {printf("It takes %d seconds to reach the target position, let me show you the way.\n",p[n-1][m-1].t);
        	print_path(n-1,m-1);//递归输出结果
        }
        else
        printf("God please help our poor hero.\n");
	    printf("FINISH\n");
	}
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值