hdu 1026 Ignatius and the Princess I(bfs搜索+输出路径)

题目来源:hdu-1026 Ignatius and the Princess I
Ignatius and the Princess I
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 14677 Accepted Submission(s): 4653
Special Judge

Problem Description
The Princess has been abducted by the BEelzebub feng5166, our hero Ignatius has to rescue our pretty Princess. Now he gets into feng5166’s castle. The castle is a large labyrinth. To make the problem simply, we assume the labyrinth is a N*M two-dimensional array which left-top corner is (0,0) and right-bottom corner is (N-1,M-1). Ignatius enters at (0,0), and the door to feng5166’s room is at (N-1,M-1), that is our target. There are some monsters in the castle, if Ignatius meet them, he has to kill them. Here is some rules:

1.Ignatius can only move in four directions(up, down, left, right), one step per second. A step is defined as follow: if current position is (x,y), after a step, Ignatius can only stand on (x-1,y), (x+1,y), (x,y-1) or (x,y+1).
2.The array is marked with some characters and numbers. We define them like this:
. : The place where Ignatius can walk on.
X : The place is a trap, Ignatius should not walk on it.
n : Here is a monster with n HP(1<=n<=9), if Ignatius walk on it, it takes him n seconds to kill the monster.

Your task is to give out the path which costs minimum seconds for Ignatius to reach target position. You may assume that the start position and the target position will never be a trap, and there will never be a monster at the start position.

Input
The input contains several test cases. Each test case starts with a line contains two numbers N and M(2<=N<=100,2<=M<=100) which indicate the size of the labyrinth. Then a N*M two-dimensional array follows, which describe the whole labyrinth. The input is terminated by the end of file. More details in the Sample Input.

Output
For each test case, you should output “God please help our poor hero.” if Ignatius can’t reach the target position, or you should output “It takes n seconds to reach the target position, let me show you the way.”(n is the minimum seconds), and tell our hero the whole path. Output a line contains “FINISH” after each test case. If there are more than one path, any one is OK in this problem. More details in the Sample Output.

Sample Input
5 6
.XX.1.
..X.2.
2…X.
…XX.
XXXXX.
5 6
.XX.1.
..X.2.
2…X.
…XX.
XXXXX1
5 6
.XX…
..XX1.
2…X.
…XX.
XXXXX.

Sample Output
It takes 13 seconds to reach the target position, let me show you the way.
1s:(0,0)->(1,0)
2s:(1,0)->(1,1)
3s:(1,1)->(2,1)
4s:(2,1)->(2,2)
5s:(2,2)->(2,3)
6s:(2,3)->(1,3)
7s:(1,3)->(1,4)
8s:FIGHT AT (1,4)
9s:FIGHT AT (1,4)
10s:(1,4)->(1,5)
11s:(1,5)->(2,5)
12s:(2,5)->(3,5)
13s:(3,5)->(4,5)
FINISH
It takes 14 seconds to reach the target position, let me show you the way.
1s:(0,0)->(1,0)
2s:(1,0)->(1,1)
3s:(1,1)->(2,1)
4s:(2,1)->(2,2)
5s:(2,2)->(2,3)
6s:(2,3)->(1,3)
7s:(1,3)->(1,4)
8s:FIGHT AT (1,4)
9s:FIGHT AT (1,4)
10s:(1,4)->(1,5)
11s:(1,5)->(2,5)
12s:(2,5)->(3,5)
13s:(3,5)->(4,5)
14s:FIGHT AT (4,5)
FINISH
God please help our poor hero.
FINISH

题目大意:
输入一个字符型的迷宫,要从左上角走到右下角,求所需的最短时间及所走路线,每一步只能走上、下、左、右,不能斜着走,图为’.’表示可以走,并且每步花费时间为1秒,当图为’数字‘时表示需要花费数字秒时间停留,故走过此处需花费时间为:map[][]-‘0’+1;若图为’X’,表示不可走。
题目分析:
此题为迷宫搜索求最短路题,并且输出要包括路径,算是典型的搜索题吧。此题我使用的是bfs搜索,首先需建立一个结构体用来存放走到每个位置的坐标及花费的总时间,使用bfs当然就要用优先队列,在此队列中,把花费时间少的放在队首;另外需要建立一个结构体用来存放所走的最短路线;然后在找到最短路径时依次输出路径即可。
AC代码:

#include<stdio.h>
#include<string.h>
#include<queue>
#define MAX 110
using namespace std;
char map[MAX][MAX];
int mark[MAX][MAX];
int dx[4]={1,-1,0,0};               //表示x下一步可走的方向 
int dy[4]={0,0,1,-1};               //表示y下一步可走的方向 
struct node{
    int x,y;
    int time;
    friend bool operator < (node a,node b)
    {
        return a.time > b.time;         //优先队列,输出时间短的 
    }
};
struct Edge{
    int px;
    int py;                             //用来存放前驱坐标 
};
node edge[MAX];
Edge pre[MAX][MAX];
int n,m;

void bfs(int sx,int sy)
{
    mark[sx][sy]=1;         //标记走过的坐标 
    node now,next;          //定义两个结构体,表示当前点与下一个点 
    pre[sx][sy].px=-1;      //标记终点 
    now.x=sx;
    now.y=sy;
    now.time=0;
    if(map[sx][sy]!='.')            
        now.time=map[sx][sy]-'0';
    priority_queue<node>q;  //定义优先队列 
    q.push(now);
    while(!q.empty())
    {
        now=q.top();
        q.pop();
        if(now.x==0&&now.y==0)      //若查找到起点,表明查找结束 
        {
            printf("It takes %d seconds to reach the target position, let me show you the way.\n",now.time);
            int key=1,total=now.time;
            sx=now.x,sy=now.y;
            while(pre[sx][sy].px!=-1)   //不断找前驱坐标,直至找到终点 
            {
                int tx=pre[sx][sy].px;
                int ty=pre[sx][sy].py;
                printf("%ds:(%d,%d)->(%d,%d)\n",key++,sx,sy,tx,ty);
                if(map[tx][ty]!='.')
                    for(int i=0;i<map[tx][ty]-'0';i++)
                        printf("%ds:FIGHT AT (%d,%d)\n",key++,tx,ty);
                sx=tx;
                sy=ty;
            }
            return ;
        }
        for(int i=0;i<4;i++)    //若还未查找完毕,将此点扩展出的所有满足题意的点入队列 
        {
            next.x=now.x+dx[i];
            next.y=now.y+dy[i];
            if(next.x<0||next.x>=n)
                continue;
            if(next.y<0||next.y>=m)
                continue;
            if(mark[next.x][next.y])
                continue;
            mark[next.x][next.y]=1;
            if(map[next.x][next.y]=='X')
                continue;
            if(map[next.x][next.y]=='.')
                next.time=now.time+1;
            else
                next.time=now.time+map[next.x][next.y]-'0'+1;
            pre[next.x][next.y].px=now.x;   //此处用来存放路径
            pre[next.x][next.y].py=now.y;
            q.push(next); 
        }
    }
    printf("God please help our poor hero.\n");
}
int main()
{
    while(scanf("%d%d",&n,&m)!=EOF)
    {   
        getchar();
        memset(mark,0,sizeof(mark));        //初始化标记数组 
        for(int i=0;i<n;i++)
        {
            for(int j=0;j<m;j++)
                scanf("%c",&map[i][j]);     //存入图 
            getchar();
        }
        bfs(n-1,m-1);                       //从后向前查找,则输出的时候从前往后输出即是路径 
        printf("FINISH\n");
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值