Milk Patterns(poj 3261,后缀数组)

42 篇文章 0 订阅
18 篇文章 0 订阅

http://poj.org/problem?id=3261

Milk Patterns
Time Limit: 5000MS Memory Limit: 65536K
Total Submissions: 8066 Accepted: 3673
Case Time Limit: 2000MS

Description

Farmer John has noticed that the quality of milk given by his cows varies from day to day. On further investigation, he discovered that although he can't predict the quality of milk from one day to the next, there are some regular patterns in the daily milk quality.

To perform a rigorous study, he has invented a complex classification scheme by which each milk sample is recorded as an integer between 0 and 1,000,000 inclusive, and has recorded data from a single cow over N (1 ≤N ≤ 20,000) days. He wishes to find the longest pattern of samples which repeats identically at least K (2 ≤ K ≤ N) times. This may include overlapping patterns -- 1 2 3 2 3 2 3 1 repeats 2 3 2 3 twice, for example.

Help Farmer John by finding the longest repeating subsequence in the sequence of samples. It is guaranteed that at least one subsequence is repeated at least K times.

Input

Line 1: Two space-separated integers:  N and  K 
Lines 2.. N+1:  N integers, one per line, the quality of the milk on day  i appears on the  ith line.

Output

Line 1: One integer, the length of the longest pattern which occurs at least  K times

Sample Input

8 2
1
2
3
2
3
2
3
1

Sample Output

4

Source



解析:

题意:

找出至少出现k此的最长子串

思路:

构造后缀数组,利用二分法找答案,扫一遍height数组,如果比设定答案小则开辟新段

0 MS 676 KB GNU C++

*/


#include<stdio.h>
#include<string.h>
#include<algorithm>
#include <iostream>
using namespace std;
const int maxn=20010;
int s[maxn];
int sa[maxn],t[maxn],t2[maxn],c[maxn],height[maxn],rank[maxn];
int vis[maxn];
void build_sa(int n,int m)
{
int i,*x=t,*y=t2;
for(i=0;i<m;i++)c[i]=0;
for(i=0;i<n;i++)c[x[i]=s[i]]++;
for(i=1;i<m;i++)c[i]+=c[i-1];
for(i=n-1;i>=0;i--)sa[--c[x[i]]]=i;
for(int k=1;k<=n;k<<=1)
{
int p=0;
for(i=n-k;i<n;i++)y[p++]=i;
for(i=0;i<n;i++)if(sa[i]>=k)y[p++]=sa[i]-k;
for(i=0;i<m;i++)c[i]=0;
for(i=0;i<n;i++)c[x[y[i]]]++;
for(i=1;i<m;i++)c[i]+=c[i-1];
for(i=n-1;i>=0;i--)sa[--c[x[y[i]]]]=y[i];
swap(x,y);
p=1;x[sa[0]]=0;
for(i=1;i<n;i++)
x[sa[i]]=y[sa[i-1]]==y[sa[i]]&&y[sa[i-1]+k]==y[sa[i]+k] ?p-1:p++;
if(p>=n)break;
m=p;
}
}
void getheight(int n)
{
int i,j,k=0;
for(i=0;i<n;i++)rank[sa[i]]=i;
for(i=0;i<n;i++)
{
if(k)k--;
j=sa[rank[i]-1];
while(s[i+k]==s[j+k])k++;
//printf("k==%d\n",k);
height[rank[i]]=k;
}
}
int check(int n,int len,int k)
{
int a=1;
for(int i=2;i<=n;i++)
{
if(height[i]<len)//当出现比当前的长度小时开劈一个新的段
{
a=1;
if(a>=k)
return i;//每一步都要判断是否满足条件 
}
else
{
a++;
if(a>=k)
return i;
}
}
return -1;
}
int main()
{
    int n,k,i,ans;
    while(scanf("%d%d",&n,&k)!=EOF)
    {    int m=0;
    	for(i=0;i<n;i++)
    	 {
    	 	scanf("%d",&s[i]);
    	 	if(s[i]>m)
    	 	 m=s[i];
 }
build_sa(n+1,m+1);
getheight(n);
int l=1,r=n;
int mid;
ans=0;
while(l<=r)//利用二分法找答案
{mid=(l+r)/2;
 int x=check(n,mid,k);
 if(x==-1)
   r=mid-1;
  else
  {
  	ans=mid;//因为是找最长子串,所以答案是尽量往大的一边取
  	l=mid+1;
  }
 // printf("ans=%d\n",ans);
}
     printf("%d\n",ans);
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值