hdu 1042 N! 高精度乘法

Time Limit: 10000/5000 MS (Java/Others) Memory Limit: 262144/262144 K (Java/Others)
Total Submission(s): 81565 Accepted Submission(s): 23924

Problem Description
Given an integer N(0 ≤ N ≤ 10000), your task is to calculate N!

Input
One N in one line, process to the end of file.

Output
For each N, output N! in one line.

Sample Input
1
2
3

Sample Output
1
2
6

#include <iostream>
#include <cstdio>
#include <algorithm>
#include <string>
#include <cstring>
using namespace std;
int a[10000000];
int main() {
    int n;  
    while(cin>>n) {
        memset(a,0,sizeof(a));
        a[0]=1;
        int tmp;
        int flag=0;//高位数 
        for(int i=2;i<=n;i++) {
            int t=flag;
            for(int j=0;j<=t;j++) {
                tmp+=a[j]*i;
                a[j]=tmp%10;
                tmp=tmp/10;//保存下一位的进数 
            }
            while(tmp) {
                a[++flag]=tmp%10;
                tmp=tmp/10;
            } 
        }
        int x;
        for(int i=10000000;i>=0;i--) {
            if(a[i]) {
                x=i;
                break;
            }
        } 
        for(int i=x;i>=0;i--) {
            printf("%d",a[i]);
        }
        printf("\n");
    }
    return 0;
} 
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值