Problem Description
Everybody knows any number can be combined by the prime number.
Now, your task is telling me what position of the largest prime factor.
The position of prime 2 is 1, prime 3 is 2, and prime 5 is 3, etc.
Specially, LPF(1) = 0.
Input
Each line will contain one integer n(0 < n < 1000000).
Output
Output the LPF(n).
Sample Input
1
2
3
4
5
Sample Output
0
1
2
1
3
问你一个数的最大质因子的素数表中的位置,预处理一下
#include <iostream>
#include <cstdio>
#include <algorithm>
using namespace std;
const int maxn=1000000+10;
int prime[maxn];
int pos[maxn];
int cnt=1;
/*
求一个数最大质因子在素数表的位置
普通筛
*/
void init() {
//pos[1]=0;
for(int i=2;i<maxn;i++) {
if(prime[i]==0) {
pos[i]=cnt++;
for(int j=i;j<maxn;j+=i) prime[j]=i;
}
}
}
int main() {
int n;
init();
while(scanf("%d",&n)!=EOF) {
printf("%d\n",pos[prime[n]]);
}
return 0;
}