HDU.4764 Stone

Stone

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1753    Accepted Submission(s): 1260


Problem Description
Tang and Jiang are good friends. To decide whose treat it is for dinner, they are playing a game. Specifically, Tang and Jiang will alternatively write numbers (integers) on a white board. Tang writes first, then Jiang, then again Tang, etc... Moreover, assuming that the number written in the previous round is X, the next person who plays should write a number Y such that 1 <= Y - X <= k. The person who writes a number no smaller than N first will lose the game. Note that in the first round, Tang can write a number only within range [1, k] (both inclusive). You can assume that Tang and Jiang will always be playing optimally, as they are both very smart students.
 

Input
There are multiple test cases. For each test case, there will be one line of input having two integers N (0 < N <= 10^8) and k (0 < k <= 100). Input terminates when both N and k are zero.
 

Output
For each case, print the winner's name in a single line.
 

Sample Input
 
 
1 1 30 3 10 2 0 0
 

Sample Output
 
 
Jiang Tang Jiang
 

题目大意: tang和jiang比赛,tang先取一个1 - k的数字,之后每人取一个数字要求比上一个数字多1-k。先取到>=n的人输掉,问获胜者。
分析:此题和抢30的游戏一样的,可以控制每两个人增长(1 + k),所以只要判断(n - 1) % (1 + k) == 0,就可以判断输赢。
AC代码:
#include <stdio.h>
#include <stdlib.h>

int main()
{
    int n,k;
    while(scanf("%d%d",&n,&k)&&k&&n)
    {
        int r=(n-1)%(k+1);
        if(r==0)
            printf("Jiang\n");
        else
            printf("Tang\n");
    }
    return 0;
}

刚看完巴什博奕(Bash Game),这道题就是可以直接套用的一道题。
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

黎曼猜想·

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值