Lake Counting (DFS )

Due to recent rains, water has pooled in various places in Farmer John's field, which is represented by a rectangle of N x M (1 <= N <= 100; 1 <= M <= 100) squares. Each square contains either water ('W') or dry land ('.'). Farmer John would like to figure out how many ponds have formed in his field. A pond is a connected set of squares with water in them, where a square is considered adjacent to all eight of its neighbors.

Given a diagram of Farmer John's field, determine how many ponds he has.
Input
* Line 1: Two space-separated integers: N and M

* Lines 2..N+1: M characters per line representing one row of Farmer John's field. Each character is either 'W' or '.'. The characters do not have spaces between them.
Output
* Line 1: The number of ponds in Farmer John's field.
Sample Input
10 12
W........WW.
.WWW.....WWW
....WW...WW.
.........WW.
.........W..
..W......W..
.W.W.....WW.
W.W.W.....W.
.W.W......W.
..W.......W.

Sample Output
3
Hint
OUTPUT DETAILS:

There are three ponds: one in the upper left, one in the lower left,and one along the right side.


题意分析:给你一块地,W表示有水的地方,‘.’表示地是干的,若一个W与周围的W紧挨着则他们是一整块池塘,问你一共有多少块池塘

思路:从第一行第一列开始扫,遇到W就进入dfs, dfs怎么实现呢?  定义八个方向,上下左右,左上左下,右上右下,表示要搜索的地方,若越界了就continue,否则就判断是否下一块是不是W,若是则将他清除(置为'.')dfs扫完了就return,找到的数量cnt++,返回到二维数组中去,继续扫。



AC代码:


#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
#include<cmath>
#include<cstdlib>
#include<queue>
#include<set>
#include<map>
#include<vector>
#include<stack>
using namespace std;
#define ll long long
char field[105][105];
int dir[8][2]={{1,0},{1,1},{0,1},{-1,1},{-1,0},{-1,-1},{0,-1},{1,-1}};
struct NODE{
    int x,y;
};
int n,m;
void dfs(int i,int j){
    NODE first;
    first.x=i;
    first.y=j;
    queue<NODE> q;
    q.push(first);
    while(!q.empty()){
        first=q.front();
        q.pop();
        for(int i=0;i<8;i++){
            NODE tmp;
            tmp.x=first.x+dir[i][0];
            tmp.y=first.y+dir[i][1];
            if(tmp.x<0||tmp.y<0||tmp.x>=n||tmp.y>=m)continue;
            if(field[tmp.x][tmp.y]=='W'){
                q.push(tmp);
                field[tmp.x][tmp.y]='.';
            }
        }
    }
    return ;
}
int main()
{
    scanf("%d%d",&n,&m);
    for(int i=0;i<n;i++)
        scanf("%s",field[i]);
    int cnt=0;
    for(int i=0;i<n;i++)
        for(int j=0;j<m;j++)
        if(field[i][j]=='W'){
            cnt++;
            dfs(i,j);
        }
    printf("%d\n",cnt);
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值