Lake Counting DFS水题

Description

Due to recent rains, water has pooled in various places in Farmer John's field, which is represented by a rectangle of N x M (1 <= N <= 100; 1 <= M <= 100) squares. Each square contains either water ('W') or dry land ('.'). Farmer John would like to figure out how many ponds have formed in his field. A pond is a connected set of squares with water in them, where a square is considered adjacent to all eight of its neighbors. 

Given a diagram of Farmer John's field, determine how many ponds he has.

Input

* Line 1: Two space-separated integers: N and M 

* Lines 2..N+1: M characters per line representing one row of Farmer John's field. Each character is either 'W' or '.'. The characters do not have spaces between them.

Output

* Line 1: The number of ponds in Farmer John's field.

Sample Input

10 12
W........WW.
.WWW.....WWW
....WW...WW.
.........WW.
.........W..
..W......W..
.W.W.....WW.
W.W.W.....W.
.W.W......W.
..W.......W.

Sample Output

3
 
#include <stdio.h>
#define  max 102
int dx[8]={-1,-1,-1,0,0,1,1,1};
int dy[8]={-1,0,1,-1,1,-1,0,1};
char map[max][max];
int x[max*100],y[max*100];
int n,m,num=0;
void DFS(int s,int k){
	int x1,y1;
	int i;
	for(i=0;i<8;++i){
		x1=s+dx[i];
		y1=k+dy[i];
		if(x1>=1&&x1<=n&&y1>=1&&y1<=m&&map[x1][y1]=='W'){
			map[x1][y1]='.';
			DFS(x1,y1);
		}
	}		
	return ;
} 
int main(){
//	freopen("input.txt","r",stdin);
	int i,j,s=0,k=0;
	scanf("%d%d",&n,&m);
	for(i=1;i<=n;++i)
	for(j=1;j<=m;++j){
		scanf(" %c",&map[i][j]);
		if(map[i][j]=='W'){
			x[s++]=i;
			y[k++]=j;
		}
	}
	for(i=0;i<s;++i){
		if(map[x[i]][y[i]]=='W'){
			map[x[i]][y[i]]='.';
			DFS(x[i],y[i]);
			++num;			
		}	
	}
	printf("%d\n",num);
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值