1154 Vertex Coloring (25分)

34 篇文章 0 订阅

A proper vertex coloring is a labeling of the graph’s vertices with colors such that no two vertices sharing the same edge have the same color. A coloring using at most k colors is called a (proper) k-coloring.

Now you are supposed to tell if a given coloring is a proper k-coloring.

Input Specification:
Each input file contains one test case. For each case, the first line gives two positive integers N and M (both no more than 10
​4
​​ ), being the total numbers of vertices and edges, respectively. Then M lines follow, each describes an edge by giving the indices (from 0 to N−1) of the two ends of the edge.

After the graph, a positive integer K (≤ 100) is given, which is the number of colorings you are supposed to check. Then K lines follow, each contains N colors which are represented by non-negative integers in the range of int. The i-th color is the color of the i-th vertex.

Output Specification:
For each coloring, print in a line k-coloring if it is a proper k-coloring for some positive k, or No if not.

Sample Input:
10 11
8 7
6 8
4 5
8 4
8 1
1 2
1 4
9 8
9 1
1 0
2 4
4
0 1 0 1 4 1 0 1 3 0
0 1 0 1 4 1 0 1 0 0
8 1 0 1 4 1 0 5 3 0
1 2 3 4 5 6 7 8 8 9
Sample Output:
4-coloring
No
6-coloring
No

其实10000个结点就应该用领接表了,但是我好懒,所以用了邻接矩阵,但是不出意外内存超限。还是用了邻接表,但是我一开始进行判断的方式是很多很多重循环,也就是第j个数和后面的数依次比较color,如果相同,再遍历j的邻接结点们,如果两个结点有通路,就是flag等于false,但是超时了。
所以用了另外的比较方式,直接遍历当前结点的邻接节点们,如果两个color相等,直接false

#include<iostream>
#include<unordered_map>
#include<vector>
using namespace std;
const int maxn = 10001;
vector<int> Adj[maxn];
int main(){
    int n,m;
    cin>>n>>m;
    int u,v;
    for(int i = 0; i < m; i++){
        cin>>u>>v;
        Adj[u].push_back(v);
        Adj[v].push_back(u);
    }
    int q;
    cin>>q;
    for(int i = 0; i < q; i++){
        int color[maxn];
        unordered_map<int,int> ma;
        bool flag = true;
        for(int j = 0; j < n; j++){
            cin>>color[j];
            ma[color[j]]++;
        }
        for(int j = 0; j < n; j++){
            for(int l = 0; l < Adj[j].size(); l++){
                if(color[j] == color[Adj[j][l]]){
                    flag = false;
                    break;
                }
            }
        }
        int cnt = 0;
        for(unordered_map<int,int>::iterator it = ma.begin(); it!=ma.end(); it++){
            if(it->second != 0) cnt++;
        }
        if(flag == false) printf("No\n");
        else printf("%d-coloring\n",cnt);
    }
    return 0;
}
//领接表比较简单,遍历每个点的邻接点比较简单,判断每个点下面的邻接点和它的颜色是否相等,如果相等,flag就是false
#include<vector>
#include<iostream>
#include<unordered_set>
using namespace std;
const int maxn = 10005;
vector<int> Adj[maxn];

int main(){
    int n,m;
    cin>>n>>m;
    int u,v;
    for(int i = 0; i < m; i++){
        cin>>u>>v;
        Adj[u].push_back(v);
        Adj[v].push_back(u);
    }
    int q;
    cin>>q;
    for(int i = 0; i < q; i++){
        vector<int> color(n+1);
        unordered_set<int> colorSize;
        bool flag = true;
        for(int j = 0; j < n; j++){
            cin>>color[j];
            colorSize.insert(color[j]);
        }
        for(int j = 0; j < n; j++){
            for(int l = 0; l < Adj[j].size(); l++){
                if(color[j] == color[Adj[j][l]]){
                    flag = false;
                }
            }
            if(flag == false) break;
        }
        if(flag == false) cout<<"No\n";
        else cout<<colorSize.size()<<"-coloring\n";
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值