H - Tiling a Grid With Dominoes HDU - 1992

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1992
We wish to tile a grid 4 units high and N units long with rectangles (dominoes) 2 units by one unit (in either orientation). For example, the figure shows the five different ways that a grid 4 units high and 2 units wide may be tiled.

Write a program that takes as input the width, W, of the grid and outputs the number of different ways to tile a 4-by-W grid.

Input
The first line of input contains a single integer N, (1 ≤ N ≤ 1000) which is the number of datasets that follow.
Each dataset contains a single decimal integer, the width, W, of the grid for this problem instance.
Output
For each problem instance, there is one line of output: The problem instance number as a decimal integer (start counting at one), a single space and the number of tilings of a 4-by-W grid. The values of W will be chosen so the count will fit in a 32-bit integer.
Sample Input

3
2
3
7

Sample Output

1 5
2 11
3 781

矩阵快速幂

#include <iostream>
#include <cstring>
#include <cstdio>
#include <queue>
#include <stack>
#include <iomanip>
using namespace std;
long long iter[5][5] = {{1,1,1,1,0},{1,0,0,0,0},{2,0,1,0,0},{1,0,0,0,1},{0,0,0,1,0}};//the iteration of Matrix
void copyMatrix(long long a[][5],long long b[][5]){
    for(int i = 0;i < 5;++i){
        for(int j = 0;j < 5;++j){
            a[i][j] = b[i][j];
        }
    }
}
void caculateMatrix(long long a[][5],long long b[][5]){ // a = a * b
    long long c[5][5] = {0};
    for(int i = 0;i < 5;++i){
        for(int j = 0;j < 5;++j){
            for(int k = 0;k < 5;++k){
                c[i][j] = c[i][j] + a[i][k] * b[k][j];
            }
        }
    }
    copyMatrix(a,c);
}
long long quickMatrixCaculate(int k){
    long long f[5] = {5,1,2,1,1};//like (f[n],f[n - 1])
    long long cur[5][5] = {{1,0,0,0,0},{0,1,0,0,0},{0,0,1,0,0},{0,0,0,1,0},{0,0,0,0,1}};//the unit Matrix
    long long p[5][5];
    copyMatrix(p,iter);
    while(k){
        if(k & 1){
            caculateMatrix(cur,p);
        }
        caculateMatrix(p,p);
        k >>= 1;
    }
    long long sum = 0;
    for(int i = 0;i < 5;++i){
        sum = sum + f[i] * cur[i][0];
    }
    return sum;
}
int main()
{
    int T,n,t = 0;
    cin >> T;
    while(T--){
        t++;
        cout << t << " ";
        cin >> n;
        if(n == 2){
            printf("5\n");
            continue;
        }
        if(n == 1){
            printf("1\n");
            continue;
        }
        cout << quickMatrixCaculate(n - 2) << endl;
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值