D - Key Task HDU - 1885

链接: http://acm.hdu.edu.cn/showproblem.php?pid=1885
The Czech Technical University is rather old — you already know that it celebrates 300 years of its existence in 2007. Some of the university buildings are old as well. And the navigation in old buildings can sometimes be a little bit tricky, because of strange long corridors that fork and join at absolutely unexpected places.

The result is that some first-graders have often di?culties finding the right way to their classes. Therefore, the Student Union has developed a computer game to help the students to practice their orientation skills. The goal of the game is to find the way out of a labyrinth. Your task is to write a verification software that solves this game.

The labyrinth is a 2-dimensional grid of squares, each square is either free or filled with a wall. Some of the free squares may contain doors or keys. There are four di?erent types of keys and doors: blue, yellow, red, and green. Each key can open only doors of the same color.

You can move between adjacent free squares vertically or horizontally, diagonal movement is not allowed. You may not go across walls and you cannot leave the labyrinth area. If a square contains a door, you may go there only if you have stepped on a square with an appropriate key before. 

Input
The input consists of several maps. Each map begins with a line containing two integer numbers R and C (1 ≤ R, C ≤ 100) specifying the map size. Then there are R lines each containing C characters. Each character is one of the following:

Note that it is allowed to have
more than one exit,

no exit at all,

more doors and/or keys of the same color, and

keys without corresponding doors and vice versa.


You may assume that the marker of your position (“*”) will appear exactly once in every map.

There is one blank line after each map. The input is terminated by two zeros in place of the map size.

Output
For each map, print one line containing the sentence “Escape possible in S steps.”, where S is the smallest possible number of step to reach any of the exits. If no exit can be reached, output the string “The poor student is trapped!” instead.

One step is defined as a movement between two adjacent cells. Grabbing a key or unlocking a door does not count as a step.

Sample Input

1 10
*........X

1 3
*#X

3 20
####################
#XY.gBr.*.Rb.G.GG.y#
####################

0 0

Sample Output

Escape possible in 9 steps.
The poor student is trapped!
Escape possible in 45 steps.

将visit标记压缩一下,由一般的bfs记录一个是否走过的状态,变成16个状态,0000~1111,对于当前
点(x,y),1111表示4个钥匙都拿着已经访问过的状态,以此为例。
具体看代码实现。
另外写的时候出现了判断有误的情况老在调试,状态压缩还是需要想清楚再写代码。

#include <iostream>
#include <string>
#include <list>
#include <cstdio>
#include <queue>
#include <cstring>
using namespace std;
int m,n,sx,sy;
bool visit[105][105][16];
char str[105][105];
int cx[] = {1,-1,0,0};
int cy[] = {0,0,1,-1};
struct road{
    int x,y,z;
    int step;
};
int judgeDoor(int x,int y){

    if(str[x][y] == 'B'){
        return 1;
    }
    else if(str[x][y] == 'Y'){
        return 2;
    }
    else if(str[x][y] == 'R'){
        return 4;
    }
    else if(str[x][y] == 'G'){
        return 8;   
    }
    return 0;
}
int judgeKey(int x,int y){
    if(str[x][y] == 'b'){
        return 1;
    }
    else if(str[x][y] == 'y'){
        return 2;
    }
    else if(str[x][y] == 'r'){
        return 4;
    }
    else if(str[x][y] == 'g'){
        return 8;
    }
    return 0;
}
queue<road> a;
void bfs(){
    road u;
    u.x = sx,u.y = sy,u.step = 0,u.z = 0;
    a.push(u);
    while(!a.empty()){
        u = a.front();
        a.pop();
        for(int i = 0;i < 4;++i){
            road v;
            v.x = u.x + cx[i];
            v.y = u.y + cy[i];
            if(v.x < 0 || v.x >= m){
                continue;
            }
            if(v.y < 0 || v.y >= n){
                continue;
            }
            v.step = u.step + 1;
            if(str[v.x][v.y] == 'X'){
                while(!a.empty()){
                    a.pop();
                }
                printf("Escape possible in %d steps.\n",v.step);
                return;
            }
            else if(str[v.x][v.y] == '.'){
                v.z = u.z;
            }
            else if(str[v.x][v.y] == '#'){
                continue;
            }
            else{
                int t = judgeDoor(v.x,v.y);
                if(t){
                    v.z = u.z;
                    if(!(v.z & t)){
                        continue;
                    }
                }
                else{
                    t = judgeKey(v.x,v.y);
                    v.z = u.z;
                    if(t){
                        if(!(v.z & t))
                            v.z += t;
                    }
                }
            }
            if(visit[v.x][v.y][v.z]){
                continue;
            }
            visit[v.x][v.y][v.z] = true;

            a.push(v);
        }   
    }
    printf("The poor student is trapped!\n");
}
int main(){
    while(cin >> m >> n){
        if(m == 0 && n == 0)
            break;
        sx = sy = 0;
        for(int i = 0;i < m;++i){
            scanf("%s",str[i]);
            for(int j = 0;j < n;++j){
                if(str[i][j] == '*'){
                    sx = i,sy = j;
                    str[sx][sy] = '.';
                    break;  
                }
            }
        }
        memset(visit,false,sizeof(visit));
        bfs();
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值