poj Number Sequence

Number Sequence
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 40636 Accepted: 11825

Description
A single positive integer i is given. Write a program to find the digit located in the position i in the sequence of number groups S1S2…Sk. Each group Sk consists of a sequence of positive integer numbers ranging from 1 to k, written one after another.
For example, the first 80 digits of the sequence are as follows:
11212312341234512345612345671234567812345678912345678910123456789101112345678910

Input
The first line of the input file contains a single integer t (1 ≤ t ≤ 10), the number of test cases, followed by one line for each test case. The line for a test case contains the single integer i (1 ≤ i ≤ 2147483647)

Output
There should be one output line per test case containing the digit located in the position i.

Sample Input

2
8
3

Sample Output

2
2
两次二分,不断缩小区间。
另外再也不用其他的二分了,直接用标准二分l <= r,然后如果有需要找第一个小的位置,或者第一个大的位置while结束后用if维护一下即可。

#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
#define ll long long
long long dp[32005];
long long c[32005];
int num[10];
void init(){
    for(int i = 1;i <= 9;++i){
        dp[i] = dp[i - 1] + 1;
        c[i] = c[i - 1] + dp[i];
    }
    for(int i = 10;i <= 99;++i){
        dp[i] = dp[i - 1] + 2;
        c[i] = c[i - 1] + dp[i];
    }
    for(int i = 100;i <= 999;++i){
        dp[i] = dp[i - 1] + 3;
        c[i] = c[i - 1] + dp[i];
    }
    for(int i = 1000;i <= 9999;++i){
        dp[i] = dp[i - 1] + 4;
        c[i] = c[i - 1] + dp[i];
    }
    for(int i = 10000;i<= 32000;++i){
        dp[i] = dp[i - 1] + 5;
        c[i] = c[i - 1] + dp[i];
    }
    //cout << c[32000] << endl;
}
int main()
{
    init();
    int t,n;
    scanf("%d",&t);
    while(t--){
        scanf("%d",&n);
        int l = 1,r = 32000,mid;
        while(l <= r){
            mid = (l + r) >> 1;
            if(c[mid] > n){
                r = mid - 1;
            }
            else if(c[mid] < n){
                l = mid + 1;
            }
            else{
                l = mid;
                break;
            }
        }
        if(c[l] > n){
            l--;
        }
        //cout << c[l] << endl;
        n -= c[l];
        if(n == 0){
            cout << l % 10 << endl;
            continue;
        }
        l = 1,r = 32000;
        while(l <= r){
            mid = (l + r) >> 1;
            if(dp[mid] > n){
                r = mid - 1;
            }
            else if(dp[mid] < n){
                l = mid + 1;
            }
            else{
                l = mid;
                break;
            }
        }
        if(dp[l] > n){
            l--;
        }
        //cout << dp[l] << endl;
        n -= dp[l];
        if(n == 0){
            cout << l % 10 << endl;
            continue;
        }
        int x = l + 1,k = 1,ans;
        while(x){
            num[k++] = x % 10;
            x /= 10;
        }
        cout << num[k - n] << endl;
    }
    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值