POJ Number Sequence 1019



Number Sequence
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 38143 Accepted: 11036

Description

A single positive integer i is given. Write a program to find the digit located in the position i in the sequence of number groups S1S2...Sk. Each group Sk consists of a sequence of positive integer numbers ranging from 1 to k, written one after another.  
For example, the first 80 digits of the sequence are as follows:  
11212312341234512345612345671234567812345678912345678910123456789101112345678910

Input

The first line of the input file contains a single integer t (1 ≤ t ≤ 10), the number of test cases, followed by one line for each test case. The line for a test case contains the single integer i (1 ≤ i ≤ 2147483647)

Output

There should be one output line per test case containing the digit located in the position i.

Sample Input

2
8
3

Sample Output

2
2

Source

Tehran 2002, First Iran Nationwide Internet Programming Contest

题意:这样一串数字11212312341234512345612345671234567812345678912345678910123456789101112345678910

给你一个位置,让求出来这个位置上的数是多少

注意  :12345678910这种序列第十位是1,不是10

分析
把1   12   123   1234  分开组,先计算一下到第多少组的时候与多少位数。用两个数组存下来第i组有多少个数,还有前i组有多少个这个用long long

对于给出的提问数字n,先判断在哪一组数到哪一组数之间,然后再判断那一位是什么


#include <string.h>
#include <stdio.h>
#include <algorithm>
#include <stdlib.h>
#include <math.h>
using namespace std;
int a[31270];   //第i组的数的多少
long long b[31270];  //前i组数的多少
void Init() //分组
{
    int i,j;
    a[1]=b[1]=1;
    int ct=1,x=10;   //ct记录这个数有几位
    for(i=2;i<31270;i++)
    {
        if(i<x)      //判断这个数有几位
        {
            a[i]=a[i-1]+ct;
        }
        else  
        {        
            x*=10;     
            ct++;   //位数+1
            a[i]=a[i-1]+ct;
        }
        b[i]=b[i-1]+a[i];
    }
}
void panduan(int x)
{
    int i,j;
    for(i=1;i<31270;i++)  //找出x在第几组
        if(x<=b[i])
            break;
    }
    int cnt=x-b[i-1];   //减去前i-1组的个数,剩下的就是它在本组的位置
    int len=0;   
    for(i=1;len<cnt;i++)   //求出来在cnt这个位置的数是,而len是这个数结束的位置。比如i=11,cnt=12,而len=13;
    {                                                //说明要舍弃这个数的后(len-cnt)位,也就是下面的除以
        len+=((int)log10((double)i))+1;
    }
    printf("%d\n",(i-1)/(int)pow(double(10),len-cnt)%10); //多循环了一次,舍弃后(len-cnt)位
}
int main()
{
    Init();
    int t,n,m,i,j;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&n);
        panduan(n);
    }
    return 0;
}






















  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值