G - Billboard HDU - 2795

 At the entrance to the university, there is a huge rectangular billboard of size h*w (h is its height and w is its width). The board is the place where all possible announcements are posted: nearest programming competitions, changes in the dining room menu, and other important information.

On September 1, the billboard was empty. One by one, the announcements started being put on the billboard.

Each announcement is a stripe of paper of unit height. More specifically, the i-th announcement is a rectangle of size 1 * wi.

When someone puts a new announcement on the billboard, she would always choose the topmost possible position for the announcement. Among all possible topmost positions she would always choose the leftmost one.

If there is no valid location for a new announcement, it is not put on the billboard (that's why some programming contests have no participants from this university).

Given the sizes of the billboard and the announcements, your task is to find the numbers of rows in which the announcements are placed. 

Input
There are multiple cases (no more than 40 cases).

The first line of the input file contains three integer numbers, h, w, and n (1 <= h,w <= 10^9; 1 <= n <= 200,000) - the dimensions of the billboard and the number of announcements.

Each of the next n lines contains an integer number wi (1 <= wi <= 10^9) - the width of i-th announcement.

Output
For each announcement (in the order they are given in the input file) output one number - the number of the row in which this announcement is placed. Rows are numbered from 1 to h, starting with the top row. If an announcement can’t be put on the billboard, output “-1” for this announcement.
Sample Input

3 5 5
2
4
3
3
3

Sample Output

1
2
1
3
-1

挺坑爹的,直接取h,n最小值居然不行,但实际上应该是可行的,因为无论怎么样,只有n次操作,并且每一次都只在一行插入,那么显然最坏情况就是所有n行都插入满(假设h > n),要么就是放不下,要么放得下最坏就是一次放了一行。另外这题还能用splay做,迟早试试。

#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cmath>
using namespace std;
struct point{
    int l,r;
    int MAX;//the MAX value int the range of [l,r] 
}a[850000];
int h,w,n,wi;
int ans;
void buildTree(int o,int l,int r){
    if(l == r){
        a[o].l = a[o].r = l;
        a[o].MAX = w;
    }
    else{
        int lo = o << 1,ro = (o << 1) | 1,mid = (l + r) >> 1;
        buildTree(lo,l,mid);
        buildTree(ro,mid + 1,r);
        a[o].l = l,a[o].r = r,a[o].MAX = w;
    }
}
void queryTree(int o){
    if(a[o].l == a[o].r){
        ans = a[o].l;
        a[o].MAX -= wi;
        return;
    }
    int lo = o << 1,ro = (o << 1) | 1;
    if(a[lo].MAX >= wi){
       queryTree(lo);
    }
    else if(a[ro].MAX >= wi){
        queryTree(ro);
    }
    a[o].MAX = max(a[lo].MAX,a[ro].MAX);
}
int main(){
    while(~scanf("%d%d%d",&h,&w,&n)){
        if(h > 200000){
            h = n;
        }
        buildTree(1,1,h);
        for(int i = 0;i < n;++i){
            scanf("%d",&wi);
            ans = -1;
            queryTree(1);
            printf("%d\n",ans);
        }
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值