Billboard HDU - 2795

At the entrance to the university, there is a huge rectangular billboard of size h*w (h is its height and w is its width). The board is the place where all possible announcements are posted: nearest programming competitions, changes in the dining room menu, and other important information.
On September 1, the billboard was empty. One by one, the announcements started being put on the billboard.

Each announcement is a stripe of paper of unit height. More specifically, the i-th announcement is a rectangle of size 1 * wi.
When someone puts a new announcement on the billboard, she would always choose the topmost possible position for the announcement. Among all possible topmost positions she would always choose the leftmost one.
If there is no valid location for a new announcement, it is not put on the billboard (that's why some programming contests have no participants from this university).
Given the sizes of the billboard and the announcements, your task is to find the numbers of rows in which the announcements are placed.
Input
There are multiple cases (no more than 40 cases).
The first line of the input file contains three integer numbers, h, w, and n (1 <= h,w <= 10^9; 1 <= n <= 200,000) - the dimensions of the billboard and the number of announcements.

Each of the next n lines contains an integer number wi (1 <= wi <= 10^9) - the width of i-th announcement.
Output
For each announcement (in the order they are given in the input file) output one number - the number of the row in which this announcement is placed. Rows are numbered from 1 to h, starting with the top row. If an announcement can't be put on the billboard, output "-1" for this announcement.
Sample Input
3 5 5
2
4
3
3
3
Sample Output
1
2
1
3

-1

#include <stdio.h>
#include <string.h>
#include <iostream>
#include <algorithm>
#define maxn 800010
using namespace std;
#define lson l,m,rt<<1
#define rson m+1,r,rt<<1|1
 int h,w,n;
 /*一想这个线段树分成的左右区间代表什么(即l、r)代表h在l、r区间之间的最大宽度还有为多少......
 昨晚没看出来模型,今早晨想起来了一个图,算是理解了题意了吧,不过还是没有能够完整的写出来g
 没能完全相通线段树在这儿维护的是啥
 */
 int MAX[maxn];
void build_tree(int l,int r,int rt)
{
    MAX[rt]=w;
    if(l==r)
        return ;
        int m=(l+r)>>1;
    build_tree(lson);
    build_tree(rson);
}
void pushup(int rt)
{
    MAX[rt]=max(MAX[rt<<1],MAX[rt<<1|1]);
}
//做了几道题感觉到这些题的模板都是要找到线段树的叶子节点进行处理,然后在通过回溯进行向上维护
int query(int a,int l,int r,int rt)
{
    if(l==r)
    {
        MAX[rt]-=a;
        return l;//
    }
    int m=(l+r)>>1;
    int ans=(MAX[rt<<1]>=a)?query(a,lson):query(a,rson);//左子数代表的h是尽可能往上的
    pushup(rt);
    return ans;
}
int main()
{
   int a;
    while(cin>>h>>w>>n)//要是h>n的话,多出来的(h-n)层已经用不到了,加个特判
    {
        h=h>n?n:h;
        build_tree(1,h,1);
        for(int i=0;i<n;++i)
        {
            scanf("%d",&a);
             if(MAX[1]<a)//理解题意写成MAX[h]<a  就WA,咦,不对,MAX[1]正好代表的是线段树的根节点,当他的最大空间不足a时,肯定就就gg了
            {
                cout<<-1<<endl;
                continue;
            }
            cout<<query(a,1,h,1)<<endl;
        }
    }
    return 0;
}

自己题解题意做出来的图:



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值