L2-006. 树的遍历
时间限制
400 ms
内存限制
65536 kB
代码长度限制
8000 B
判题程序
Standard
作者
陈越
给定一棵二叉树的后序遍历和中序遍历,请你输出其层序遍历的序列。这里假设键值都是互不相等的正整数。
输入格式:
输入第一行给出一个正整数N(<=30),是二叉树中结点的个数。第二行给出其后序遍历序列。第三行给出其中序遍历序列。数字间以空格分隔。
输出格式:
在一行中输出该树的层序遍历的序列。数字间以1个空格分隔,行首尾不得有多余空格。
输入样例:
7
2 3 1 5 7 6 4
1 2 3 4 5 6 7
输出样例:
4 1 6 3 5 7 2
提交代码
后序遍历从右往从依次是父节点,右子节点,左子节点,于是应该先递归建右子树。
#include <iostream>
#include <cstring>
#include <queue>
#include <set>
#include <vector>
#include <cmath>
#include <stack>
#include <string>
#include <queue>
#include <algorithm>
#include <cstdio>
#include <map>
using namespace std;
#define INF 0x3f3f3f3f
int n, a[35], b[35], k;
struct node {
int value;
node *left, *right;
node() {
left = right = NULL;
}
};
void buildTree(int l,int r,node *p) {
if (l > r) {
return;
}
for (int i = l; i <= r; ++i) {
if (b[i] == a[k]) {
k--;
p->value = b[i];
p->right = new node();
p->right->value = -1;
buildTree(i + 1, r, p->right);
p->left = new node();
p->left->value = -1;
buildTree(l, i - 1, p->left);
break;
}
}
}
void bfs(node *p) {
queue<node*> q;
q.push(p);
while (!q.empty()) {
node* t = q.front();
q.pop();
if (t == p) {
printf("%d", t->value);
}
else {
if(t->value != -1)
printf(" %d", t->value);
}
if(t->left != NULL)
q.push(t->left);
if(t->right != NULL)
q.push(t->right);
}
putchar('\n');
}
int main() {
scanf("%d", &n);
for (int i = 1; i <= n; ++i) {
scanf("%d", &a[i]);
}
for (int i = 1; i <= n; ++i) {
scanf("%d", &b[i]);
}
node *head = new node();
k = n;
buildTree(1, n, head);
bfs(head);
return 0;
}