A - Keywords Search HDU - 2222

In the modern time, Search engine came into the life of everybody like Google, Baidu, etc.
Wiskey also wants to bring this feature to his image retrieval system.
Every image have a long description, when users type some keywords to find the image, the system will match the keywords with description of image and show the image which the most keywords be matched.
To simplify the problem, giving you a description of image, and some keywords, you should tell me how many keywords will be match.
Input
First line will contain one integer means how many cases will follow by.
Each case will contain two integers N means the number of keywords and N keywords follow. (N <= 10000)
Each keyword will only contains characters ‘a’-‘z’, and the length will be not longer than 50.
The last line is the description, and the length will be not longer than 1000000.
Output
Print how many keywords are contained in the description.
Sample Input
1
5
she
he
say
shr
her
yasherhs
Sample Output
3
注意到search那里,如果说在待匹配串匹配时出现了某个单词结点可匹配,则将val[u] = 0,这样可以避免重复计数,是否会影响到last数组的使用呢,显然不会,因为last[u]是根据u结点确定的单词结点而确定的另一个可匹配的值,事实上,一旦将val[u] = 0,last[u]所标记的单词结点也已经计数过了。另如果说有多个待匹配串时这么做就不适用了,此时可以考虑使用set去重,或者记录将val置0的结点。

#include <iostream>
#include <string>
#include <set>
#include <algorithm>
#include <cmath>
#include <cstring>
#include <set>
#include <map>
#include <vector>
#include <queue>
#include <cstdio>
using namespace std;
#define INF 0x3f3f3f3f
int ch[500005][26], sz, val[500005], last[500005], f[500005], sum;
char str[1000005];
void insert() {
    int u = 0;
    for (int i = 0; str[i] != '\0'; ++i) {
        int o = str[i] - 'a';
        if (!ch[u][o]) {
            memset(ch[sz], 0, sizeof(ch[sz]));
            ch[u][o] = sz++;
        }
        u = ch[u][o];
    }
    val[u]++;
}
void getfail() {
    int u = 0;
    queue<int> q;
    f[0] = 0;
    for (int i = 0; i < 26; ++i) {
        int t = ch[u][i];
        if (t) {
            last[t] = f[t] = 0;
            q.push(t);
        }
    }
    while (!q.empty()) {
        u = q.front();
        q.pop();
        for (int i = 0; i < 26; ++i) { 
            int t = ch[u][i];
            if (!t) {
                ch[u][i] = ch[f[u]][i];
                continue;
            }
            q.push(t);
            int v = f[u];// t结点处失配则应根据u节点的失配去找
            while (v && !ch[v][i]) {
                v = f[v];
            }
            f[t] = ch[v][i];//t的失配应转到ch[v][i],实际上相当于ch[v][i]是有的
            last[t] = val[f[t]] ? f[t] : last[f[t]];
        }
    }
}
void search(int u) {
    while (u) {
        sum += val[u];
        val[u] = 0;
        u = last[u];
    }
}
void solve() {
    int u = 0;
    for (int i = 0; str[i] != '\0'; ++i) {
        int o = str[i] - 'a';
        u = ch[u][o];
        if (val[u]) {
            search(u);
        }
        else if (last[u]) {
            search(last[u]);
        }
    }
}
int main() {
    int T, n;
    cin >> T;
    while (T--) {
        cin >> n;
        memset(val, 0, sizeof(val));
        memset(ch[0], 0, sizeof(ch[0]));
        sz = 1;
        for (int i = 0; i < n; ++i) {
            scanf("%s", str);
            insert();
        }
        getfail();
        scanf("%s", str);
        sum = 0;
        solve();
        cout << sum << endl;
    }
    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值