POJ - 3279 Fliptile

该博客主要解析了POJ-3279题目的解决方案,题目要求帮助奶牛计算翻转网格中瓷砖以使所有瓷砖白色面朝上的最小操作数。博主给出了C++代码实现,通过枚举第一行的翻转状态找到最优解,并输出最小操作数及对应翻转位置。
摘要由CSDN通过智能技术生成

POJ - 3279 Fliptile

题目

Farmer John knows that an intellectually satisfied cow is a happy cow who will give more milk. He has arranged a brainy activity for cows in which they manipulate an M × N grid (1 ≤ M ≤ 15; 1 ≤ N ≤ 15) of square tiles, each of which is colored black on one side and white on the other side.
As one would guess, when a single white tile is flipped, it changes to black; when a single black tile is flipped, it changes to white. The cows are rewarded when they flip the tiles so that each tile has the white side face up. However, the cows have rather large hooves and when they try to flip a certain tile, they also flip all the adjacent tiles (tiles that share a full edge with the flipped tile). Since the flips are tiring, the cows want to minimize the number of flips they have to make.

Help the cows determine the minimum number of flips required, and the locations to flip to achieve that minimum. If there are multiple ways to achieve the task with the minimum amount of flips, return the one with the least lexicographical ordering in the output when considered as a string. If the task is impossible, print one line with the word “IMPOSSIBLE”.

Input

Line 1: Two space-separated integers: M and N
Lines 2…M+1: Line i+1 describes the colors (left to right) of row i of the grid with N space-separated integers which are 1 for black and 0 for white

Output

Lines 1…M: Each line contains N space-separated integers, each specifying how many times to flip that particular location.

Sample Input

4 4
1 0 0 1
0 1 1 0
0 1 1 0
1 0 0 1

Sample Output

0 0 0 0
1 0 0 1
1 0 0 1
0 0 0 0

题解

看最后一行是否满足题意即可

/*************************************************************************
    > Problem: POJ - 3279 Fliptile
    > Author: ALizen_
    > Mail: hhu_zyh@qq.com
    > Blog: https://blog.csdn.net/Jame_19?spm=1001.2101.3001.5343
*************************************************************************/
#include<set>
#include<map>
#include<cmath>
#include<queue>
#include<stack>
#include<vector>
#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
#define re register int
#define sf(x) scanf("%d",&x)
#define pf(x) printf("%d\n",x)
#define slf(x) scanf("%lld",&x)
#define plf(x) printf("%lld\n",x)
#define MEM(a,b) memset((a),(b),sizeof(a))
#define ref(i,a,b) for(re i = a ; i >= b ; -- i)
#define fer(i,a,b) for(re i = a ; i <= b ; ++ i)
using namespace std;
typedef long long LL;
#define INF 0x3f3f3f3f
bool a[20][20];   //存图
bool b[20][20];   //保存当前翻转方案
bool c[20][20];   //保存最优解
int d[5][2] = { { -1, 0 }, { 1, 0 }, { 0, 0 }, { 0, -1 }, { 0, 1 } };
int ans = INF;
int n, m;
bool getcolor(int x, int y)    //得到x,y的颜色
{
	int res = a[x][y];
	for (int i = 0; i < 5; i++)
	{
		int fx = x + d[i][0], fy = y + d[i][1];
		if (fx >= 1 && fx <= n && fy >= 1 && fy <= m) res += b[fx][fy];
	}
	return res % 2;
}
int solve()
{
	int res = 0;
	for (int i = 2; i <= n; i++)    //从第二行开始检查是否需要翻转
		for (int j = 1; j <= m; j++)
			if (getcolor(i - 1, j)) b[i][j] = 1;
	for (int i = 1; i <= m; i++)     //检查最后一行是否全为白色
		if (getcolor(n, i)) return INF;
	for (int i = 1; i <= n; i++)    //统计翻转次数 
		for (int j = 1; j <= m; j++)
			res += b[i][j];
	return res;
}
int main()
{
	scanf("%d%d", &n, &m);
	for (int i = 1; i <= n; i++)
		for (int j = 1; j <= m; j++)
			scanf("%d", &a[i][j]);
	for (int s = 0; s < 1 << m; s++)   //按照字典序枚举第一行所以翻转可能
	{
		memset(b, false, sizeof b);
		for (int i = 1; i <= m; i++)
			b[1][i] = s >> (m - i) & 1;
		int t = solve();
		if (t < ans)
		{
			ans = t;
			memcpy(c, b, sizeof b);
		}
	}
	if (ans == INF) printf("IMPOSSIBLE\n");
	else 
	{
		for (int i = 1; i <= n; i++)
		{
			for (int j = 1; j <= m; j++)
				printf("%d ", c[i][j]);
			printf("\n");
		}
	}
	return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值