POJ 3279 - Fliptile

7 篇文章 0 订阅

D - Fliptile
Time Limit:2000MS     Memory Limit:65536KB     64bit IO Format:%I64d & %I64u

Description

Farmer John knows that an intellectually satisfied cow is a happy cow who will give more milk. He has arranged a brainy activity for cows in which they manipulate an M × N grid (1 ≤ M ≤ 15; 1 ≤ N ≤ 15) of square tiles, each of which is colored black on one side and white on the other side.

As one would guess, when a single white tile is flipped, it changes to black; when a single black tile is flipped, it changes to white. The cows are rewarded when they flip the tiles so that each tile has the white side face up. However, the cows have rather large hooves and when they try to flip a certain tile, they also flip all the adjacent tiles (tiles that share a full edge with the flipped tile). Since the flips are tiring, the cows want to minimize the number of flips they have to make.

Help the cows determine the minimum number of flips required, and the locations to flip to achieve that minimum. If there are multiple ways to achieve the task with the minimum amount of flips, return the one with the least lexicographical ordering in the output when considered as a string. If the task is impossible, print one line with the word "IMPOSSIBLE".

Input

Line 1: Two space-separated integers:  M and  N
Lines 2..  M+1: Line  i+1 describes the colors (left to right) of row i of the grid with  N space-separated integers which are 1 for black and 0 for white

Output

Lines 1..  M: Each line contains  N space-separated integers, each specifying how many times to flip that particular location.

Sample Input

4 4
1 0 0 1
0 1 1 0
0 1 1 0
1 0 0 1

Sample Output

0 0 0 0
1 0 0 1
1 0 0 1
0 0 0 0

题目意思,翻转一张牌的时候,其上下左右的牌都会随着翻转,求使所有牌变为0的最少翻转次数

枚举第一行所有翻转情况,一次推出下一行的翻转情况,到最后一行的时候判断是否全为0,为0则更新答案


#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;

#define N 20
#define INF 0x3f3f3f3f

int n,m;
int a[N][N];
int f[N][N];
int ans[N][N];

int vx[]={0,-1,0,0};
int vy[]={0,0,-1,1};

bool check(int x,int y){
	return x>=0 && y>=0 && x<n && y<m;
}

int get(int x,int y){
	int ret=a[x][y];
	for (int i=0;i<4;i++){
		int tx=x+vx[i];
		int ty=y+vy[i];
		if (check(tx,ty))
			ret+=f[tx][ty];
	}

	return ret&1;
}

int dfs(int k){
	if (k==n-1){
		for (int i=0;i<m;i++)
			if (get(n-1,i))
				return INF;
		int ret=0;
		for (int i=0;i<n;i++)
			for (int j=0;j<m;j++)
				ret+=f[i][j];
		return ret;
	}

	for (int i=0;i<m;i++)
		f[k+1][i]=get(k,i);

	return dfs(k+1);
}

int main(){
	scanf("%d%d",&n,&m);
	for (int i=0;i<n;i++)
		for (int j=0;j<m;j++)
			scanf("%d",&a[i][j]);

	int max=1<<m;
	int sum=INF;
	memset(ans,0,sizeof(ans));
	for (int i=0;i<max;i++){
		int temp=i;
		memset(f,0,sizeof(f));
		for (int j=m-1;j>=0;j--){
			f[0][j]=temp&1;
			temp>>=1;
		}
		int com=dfs(0);
		//cout<<i<<' '<<com<<endl;
		if (com<sum){
			sum=com;
			memcpy(ans,f,sizeof(f));
		}
	}

	if (sum==INF){
		printf("IMPOSSIBLE\n");
		return 0;
	}
	for (int i=0;i<n;i++){
		printf("%d",ans[i][0]);
		for (int j=1;j<m;j++)
			printf(" %d",ans[i][j]);
		printf("\n");
	}

	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值