hdu1081(dp)(多维化成一维的最大子序列)

To The Max

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 13473    Accepted Submission(s): 6424


Problem Description
Given a two-dimensional array of positive and negative integers, a sub-rectangle is any contiguous sub-array of size 1 x 1 or greater located within the whole array. The sum of a rectangle is the sum of all the elements in that rectangle. In this problem the sub-rectangle with the largest sum is referred to as the maximal sub-rectangle.

As an example, the maximal sub-rectangle of the array:

0 -2 -7 0
9 2 -6 2
-4 1 -4 1
-1 8 0 -2

is in the lower left corner:

9 2
-4 1
-1 8

and has a sum of 15.
 

Input
The input consists of an N x N array of integers. The input begins with a single positive integer N on a line by itself, indicating the size of the square two-dimensional array. This is followed by N 2 integers separated by whitespace (spaces and newlines). These are the N 2 integers of the array, presented in row-major order. That is, all numbers in the first row, left to right, then all numbers in the second row, left to right, etc. N may be as large as 100. The numbers in the array will be in the range [-127,127].
 

Output
Output the sum of the maximal sub-rectangle.
 

Sample Input
  
  
4 0 -2 -7 0 9 2 -6 2 -4 1 -4 1 -1 8 0 -2
 

Sample Output
  
  
15

#include <bits/stdc++.h>
using namespace std;
const int maxn=100+5;
int dp[maxn][maxn],pic[maxn][maxn];
int main()
{
//	freopen("data.in.txt","r",stdin);
	int n;
	while(cin>>n&&n){
		
		memset(pic,0,sizeof(pic));
		memset(dp,0,sizeof(dp));
		int temp;
		for(int i=1;i<=n;i++)
			for(int j=1;j<=n;j++){
				cin>>temp;
				pic[i][j]=pic[i][j-1]+temp;
			}
		int ans=-1;
		for(int i=1;i<=n;i++){
			for(int j=i;j<=n;j++){
				dp[i][j]=0;
				for(int k=1;k<=n;k++){
					dp[i][j]=max(dp[i][j]+pic[k][j]-pic[k][i-1],pic[k][j]-pic[k][i-1]);
					if(dp[i][j]>ans)
						ans=dp[i][j];
				}
			}
		}
		cout<<ans<<endl;	
	}
	return 0;
}

代码如上,

dp[i][j]表示第i列到第j列的最大和的子矩形的值。

同时加上另一层循环k,求得每一行的第i列到第j列的值,判断是否需要相加要与dp[i][j]相加。

所以,三个循环完成了该题目目标。



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值