hdu1525Euclid's Game(博弈)

Euclid's Game

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 3839    Accepted Submission(s): 1829


Problem Description
Two players, Stan and Ollie, play, starting with two natural numbers. Stan, the first player, subtracts any positive multiple of the lesser of the two numbers from the greater of the two numbers, provided that the resulting number must be nonnegative. Then Ollie, the second player, does the same with the two resulting numbers, then Stan, etc., alternately, until one player is able to subtract a multiple of the lesser number from the greater to reach 0, and thereby wins. For example, the players may start with (25,7): 

25 7
11 7
4 7
4 3
1 3
1 0 

an Stan wins. 

 

Input
The input consists of a number of lines. Each line contains two positive integers giving the starting two numbers of the game. Stan always starts.
 

Output
For each line of input, output one line saying either Stan wins or Ollie wins assuming that both of them play perfectly. The last line of input contains two zeroes and should not be processed. 

 

Sample Input
  
  
34 12 15 24 0 0
 

Sample Output
  
  
Stan wins Ollie wins
 

Source

假设面临的状态是(a,b)(且a<b)

有几种情况,我们来讨论一下:

(1)a==0或者b%a==0

先手赢了

(2)a<b<2*b,由于只能进行减较小数的操作,即减a的操作,所以这个状态是不确定的,但是是确定步数就能赢得。

比如(a,2*a-m),m属于a到2a的开区间,

下一步是(a-m,a),再下一步便能到达终点态。

(3)b>2*b,由于先手可以通过对b减不同的数,使的第一个a<b<2*b的状态究竟是谁先取到,并且通过(2)我们知道是确定步数的,所以先手一定赢的


代码:

#include <iostream>
using namespace std;
int main(){
    int a , b ;
    while(scanf("%d%d", &a , &b ) != EOF && (a + b) ){
        if(a > b )
            swap(a , b) ;
        int flag = 1;
        //只需判断a/b==1的状态
        while(1){
            if( a == 0 ||  b % a == 0 ||  b / a >= 2) break;
            int t = a;
            a= b  - a ;
            b = t;
            flag = !flag ;
        }
        if(flag)
            puts("Stan wins");
        else puts("Ollie wins") ;
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值