HDU 1525 Euclid's Game(博弈)

Euclid’s Game

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 2926 Accepted Submission(s): 1350

Problem Description
Two players, Stan and Ollie, play, starting with two natural numbers. Stan, the first player, subtracts any positive multiple of the lesser of the two numbers from the greater of the two numbers, provided that the resulting number must be nonnegative. Then Ollie, the second player, does the same with the two resulting numbers, then Stan, etc., alternately, until one player is able to subtract a multiple of the lesser number from the greater to reach 0, and thereby wins. For example, the players may start with (25,7):

25 7
11 7
4 7
4 3
1 3
1 0

an Stan wins.

Input
The input consists of a number of lines. Each line contains two positive integers giving the starting two numbers of the game. Stan always starts.

Output
For each line of input, output one line saying either Stan wins or Ollie wins assuming that both of them play perfectly. The last line of input contains two zeroes and should not be processed.

Sample Input
34 12
15 24
0 0

Sample Output
Stan wins
Ollie wins

Source
University of Waterloo Local Contest 2002.09.28

Recommend
LL

题意:给你两个数,每次都是大数减去小数的整数倍,Stan先开始,然后是Ollie,如果谁先出现 0,b 这种情况谁就获胜了。

分析:1.当a=b时,这时候先手必胜。
     2.当a>b时,这时候有两种情况
         ①a%b=0,此时a为b的倍数,先手必胜。
         ②a>=2b,此时先手可以进行选择,进行什么选择呢?每个人都想获胜,所以他们采取的都是最利于自己的行动,Stan或者Ollie肯定知道 a%b,b 是必胜态还是必败态。如果是必败态,先手将a,b变成a%b,b,使对手面临必败态,先手赢。如果是必胜态,先手将a,b变成  a%b+b,b ,破坏掉必胜态,那么对手只有将这两个数变成 a%b,b ,先手获胜。( 25,7 这个例子就能说明②这种情况 )

综上  关键是找到必胜态
     a>b 与 b>a 情况一致
     即a==b||a%b==0||a>=2*b时先手胜
     否则就一步一步走,看到最后谁胜利。( 15,24这个例子能说明这种情况)

AC代码:

#include<iostream>
#include<cstdio>
#include<algorithm>
using namespace std;

int main(){
    int a,b;
    while(cin>>a>>b && a+b){ 
        if(a<b) swap(a,b);

        bool Stan=true;//定义一个bool型 true代表Stan  false代表Ollie 
        while(1){
            if(a==b||a%b==0||a>=2*b)
                break;
            a=a-b;
            swap(a,b);//每次都让a中存放较大的 这样省得多次判断  
            Stan=!Stan; 
        }
        if(Stan)    cout<<"Stan wins"<<endl;
        else        cout<<"Ollie wins"<<endl;
    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值