codevs2605小明学数数(异或)

题目描述 Description

小明才会学数数,妈妈就开始难为他了。告诉他N(N<=1000000)个数字,问他哪一个数字出现的次数为奇数(保证N为奇数,数据中每个数字出现的次数只有一个为奇数次,每个数字为int范围内)

输入描述 Input Description

第一行一个N;第i+1行为第i个数字

输出描述 Output Description

输出仅仅一行,为出现奇数次的那个数字

样例输入 Sample Input

5

3

6

7

6

3

样例输出 Sample Output

7

#include <bits/stdc++.h>
using namespace std;
int main()
{
    int n;
    cin>>n;
    int temp,ans=0;
    for (int i=1;i<=n;i++)
    {
        cin>>temp;
        ans=ans^temp;
    }
    cout << ans ;
    return 0;
}

错误的方法:

#include <iostream>
#include <map>
using namespace std;
map<int,int>map1;
map<int,int>map2;
int main()
{
	ios::sync_with_stdio(false);
	
	int n;
	cin>>n;
//	for(int i=0;i<n;i++)map1[i]=0;
	int temp;
	for(int i=0;i<n;i++){
		cin>>temp;
		map2[i]=temp;
		if(map1.count(temp))map1[temp]++;
		else
		map1[temp]=1;
	}
	for(int i=0;i<n;i++){
		if(map1[map2[i]]%2==1){
			cout<<map2[i];
			break;
		}
	}
	return 0;
}

空间超了,恐怖



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值