历届试题-合根植物[蓝桥杯][并查集模板]

合根植物[并查集]

time limit per testmemory limit per testinputoutput
2 seconds256 megabytesstandard inputstandard output

Description:

w星球的一个种植园,被分成 m * n 个小格子(东西方向m行,南北方向n列)。每个格子里种了一株合根植物。
这种植物有个特点,它的根可能会沿着南北或东西方向伸展,从而与另一个格子的植物合成为一体。
如果我们告诉你哪些小格子间出现了连根现象,你能说出这个园中一共有多少株合根植物吗?

Input

第一行,两个整数m,n,用空格分开,表示格子的行数、列数(1<m,n<1000)。
接下来一行,一个整数k,表示下面还有k行数据(0<k<100000)
接下来k行,第行两个整数a,b,表示编号为a的小格子和编号为b的小格子合根了。
格子的编号一行一行,从上到下,从左到右编号。
比如:5 * 4 的小格子,编号:
  1 2 3 4
  5 6 7 8
  9 10 11 12
  13 14 15 16
  17 18 19 20

Output

Example input

5 4
16
2 3
1 5
5 9
4 8
7 8
9 10
10 11
11 12
10 14
12 16
14 18
17 18
15 19
19 20
9 13
13 17

Example output

5

分析:
题意:
用并查集把同一块连在一起

Code:

#include <algorithm>
#include <iostream>
#include <cstdlib>
#include <cstring>
#include <string>
#include <cstdio>
#include <vector>
#include <bitset>
#include <cmath>
#include <ctime>
#include <queue>
#include <stack>
#include <set>
#include <map>
using namespace std;
typedef long long ll;

const int maxn = 1e6 + 5;
bool vis[maxn];
int pre[maxn];

int find_(int x) {
    return x == pre[x] ? x : pre[x] = find_(pre[x]);
}

int main() {
    int n, m, k, u, v;
    scanf("%d%d%d", &n, &m, &k);
    n *= m;
    for(int i = 0; i <= n; ++i)
        pre[i] = i, vis[i] = false;
    while(k--) {
        scanf("%d%d", &u, &v);
        u = find_(u), v = find_(v);
        pre[u] = v;
    }
    int cnt = 0;
    for(int i = 1; i <= n; ++i) {
        u = find_(i);
        if(!vis[u]) vis[u] = true, cnt++;
    }
    printf("%d\n", cnt);
    return 0;
}




评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值