HDU3986(Harry Potter and the Final Battle)-枚举最短路径+SPFA


Harry Potter and the Final Battle

Description

The final battle is coming. Now Harry Potter is located at city 1, and Voldemort is located at city n. To make the world peace as soon as possible, Of course, Harry Potter will choose the shortest road between city 1 and city n. But unfortunately, Voldemort is so powerful that he can choose to destroy any one of the existing roads as he wish, but he can only destroy one. Now given the roads between cities, you are to give the shortest time that Harry Potter can reach city n and begin the battle in the worst case.
 

Input

First line, case number t (t<=20).
Then for each case: an integer n (2<=n<=1000) means the number of city in the magical world, the cities are numbered from 1 to n. Then an integer m means the roads in the magical world, m (0< m <=50000). Following m lines, each line with three integer u, v, w (u != v,1 <=u, v<=n, 1<=w <1000), separated by a single space. It means there is a bidirectional road between u and v with the cost of time w. There may be multiple roads between two cities.
 

Output

Each case per line: the shortest time to reach city n in the worst case. If it is impossible to reach city n in the worst case, output “-1”.
 

Sample Input

     
     
3 4 4 1 2 5 2 4 10 1 3 3 3 4 8 3 2 1 2 5 2 3 10 2 2 1 2 1 1 2 2
 

Sample Output

     
     
15 -1 2
#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
#include<queue>
using namespace std;

const int N=1010;
const int M=100010;
const int INF=0xffffff;

struct Edge
{
    int u;
    int to;
    int w;
    int flag;
    int next;
} e[M];

int head[N];
int dist[N];
int path[N];
int inq[N];
int n,m,cnt,flag;

void AddEdge(int u,int v,int w)
{
    e[cnt].u=u;
    e[cnt].to=v;
    e[cnt].w=w;
    e[cnt].flag=1;
    e[cnt].next=head[u];
    head[u]=cnt++;
}

int SPFA(int s)
{
    queue<int>Q;
    for(int i=1; i<=n; i++)
    {
        dist[i]=INF;
        inq[i]=0;
    }
    dist[s]=0;
    inq[s]=1;
    Q.push(s);
    while(!Q.empty())
    {
        int u=Q.front();
        Q.pop();
        inq[u]=0;
        for(int j=head[u]; j!=-1; j=e[j].next)
        {
            int x=e[j].to;
            if(e[j].flag&&dist[x]>dist[u]+e[j].w)
            {
                dist[x]=dist[u]+e[j].w;
                if(!flag)
                    path[x]=j;
                if(!inq[x])
                {
                    Q.push(x);
                    inq[x]=1;
                }
            }
        }
    }
    return dist[n];
}

int main()
{
    //freopen("C:\\Users\\Administrator\\Desktop\\kd.txt","r",stdin);
    int t;
    scanf("%d",&t);
    while(t--)
    {
        cnt=flag=0;
        memset(head,-1,sizeof(head));
        scanf("%d%d",&n,&m);
        while(m--)
        {
        	int u,v,w;
            scanf("%d%d%d",&u,&v,&w);
            AddEdge(u,v,w);
            AddEdge(v,u,w);
        }
        memset(path,-1,sizeof(path));
        SPFA(1);
        flag=1;
        int i=n,j=-1;
        int res=-1;
        while(path[i]!=-1)
        {
            j=path[i];
            e[j].flag=e[j+1].flag=0;
            int tmp=SPFA(1);
            e[j].flag=e[j+1].flag=1;
            if(tmp>res)
                res=tmp;
            i=e[j].u;
        }
        if(res<INF)
            printf("%d\n",res);
        else
            puts("-1");
    }
}


  • 2
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值