1004 Counting Leaves (30分)

单词 - -

hierarchy:n. 层级;等级制度

  • 英 /ˈhaɪərɑːki/ 
  • 美 /ˈhaɪərɑːrki/ 

pedigree:n. 血统;家谱  adj. 纯种的

  • 英 /ˈpedɪɡriː/ 
  • 美 /ˈpedɪɡriː/ 

For the sake of simplicity:为了简单起见

sake:n. 目的;利益;理由;日本米酒 

  • 英 /seɪk; ˈsɑːki/ 
  • 美 /sek/ 

seniority:n. 年长;级别、职位高;资历;(前任者、老资格的)特权

  • 英 /ˌsiːniˈɒrəti/ 
  • 美 /ˌsiːnˈjɔːrəti/

 

1004 Counting Leaves (30分)

A family hierarchy is usually presented by a pedigree tree. Your job is to count those family members who have no child.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 0<N<100, the number of nodes in a tree, and M (<N), the number of non-leaf nodes. Then M lines follow, each in the format:

ID K ID[1] ID[2] ... ID[K]

where ID is a two-digit number representing a given non-leaf node, K is the number of its children, followed by a sequence of two-digit ID's of its children. For the sake of simplicity, let us fix the root ID to be 01.

The input ends with N being 0. That case must NOT be processed.

Output Specification:

For each test case, you are supposed to count those family members who have no child for every seniority level starting from the root. The numbers must be printed in a line, separated by a space, and there must be no extra space at the end of each line.

The sample case represents a tree with only 2 nodes, where 01 is the root and 02 is its only child. Hence on the root 01 level, there is 0 leaf node; and on the next level, there is 1 leaf node. Then we should output 0 1 in a line.

Sample Input:

2 1
01 1 02

Sample Output:

0 1

 

#include<cstdio>
#include<vector>
#include<algorithm>
using namespace std;
vector<int>v[105];
int non_leaf[105];
int maxDepth=-1;
//bool vis[105];
void DFS(int root,int depth) {
    //vis[root]=true;
    if(v[root].size()==0) {
        non_leaf[depth]++;
        maxDepth=max(maxDepth,depth);
    } else {
        for(int i=0; i<v[root].size(); i++) {
            //if(vis[v[root][i]]==false)
            DFS(v[root][i],depth+1);
        }
    }
}
int main() {
    int n,m;
    scanf("%d%d",&n,&m);
    for(int i=0; i<m; i++) {
        int id,k;
        scanf("%d%d",&id,&k);
        for(int j=0; j<k; j++) {
            int child;
            scanf("%d",&child);
            v[id].push_back(child);
        }
    }
    DFS(1,0);
    for(int i=0; i<=maxDepth; i++) {
        printf("%d",non_leaf[i]);
        if(i!=maxDepth)
            printf(" ");
    }
    return 0;
}

1.又学到了一种结果输出格式 

2.DFS仍不够熟练,此题应多加复习

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值